aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzma/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 14:41:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 14:41:11 +0000
commit0b0414e629a329c67b3fbdf449d0e5881f581e13 (patch)
tree2c346413c543356ae8803d0501004f5d5b543915 /archivers/lzma/Makefile
parentfdc6b1bb171eb93c42659c0845abf9f5a49f1711 (diff)
downloadports-0b0414e629a329c67b3fbdf449d0e5881f581e13.tar.gz
ports-0b0414e629a329c67b3fbdf449d0e5881f581e13.zip
Notes
Diffstat (limited to 'archivers/lzma/Makefile')
-rw-r--r--archivers/lzma/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/archivers/lzma/Makefile b/archivers/lzma/Makefile
index f9526e766dd0..4533d3ab9644 100644
--- a/archivers/lzma/Makefile
+++ b/archivers/lzma/Makefile
@@ -12,11 +12,9 @@ COMMENT= High-ratio LZMA compressor
CONFLICTS= lzmautils-[0-9]* xz-[0-9]*
-USES= gmake
+USES= gmake dos2unix
USE_BZIP2= yes
-NO_STAGE= yes
NO_WRKSUBDIR= yes
-USE_DOS2UNIX= yes
BUILD_WRKSRC= ${WRKSRC}/CPP/7zip/Bundles/LzmaCon
MAKEFILE= makefile.gcc
PLIST_FILES= bin/${PORTNAME}
@@ -42,11 +40,9 @@ post-patch:
${BUILD_WRKSRC}/${MAKEFILE}
do-install:
- @${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin/
-.ifndef NOPORTDOCS
- @${INSTALL} -d ${DOCSDIR}/
- @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
-.endif
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ @${INSTALL} -d ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
regression-test: build
${BUILD_WRKSRC}/${PORTNAME} b