aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzma/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-06-22 14:47:56 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-06-22 14:47:56 +0000
commit54faf09e752349e3c329f5e359cde4a5ca149004 (patch)
tree381c7b202cf4a0c32867b1a0115d556b0e4fb80c /archivers/lzma/Makefile
parent4fa523cd1aee7c4ed98a084ce1ea662808c511ee (diff)
downloadports-54faf09e752349e3c329f5e359cde4a5ca149004.tar.gz
ports-54faf09e752349e3c329f5e359cde4a5ca149004.zip
Notes
Diffstat (limited to 'archivers/lzma/Makefile')
-rw-r--r--archivers/lzma/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/archivers/lzma/Makefile b/archivers/lzma/Makefile
index 2e368e6d0806..8db5e24d03b1 100644
--- a/archivers/lzma/Makefile
+++ b/archivers/lzma/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= lzma
-PORTVERSION= 9.20
+PORTVERSION= 9.22
CATEGORIES= archivers
MASTER_SITES= SF/sevenzip/LZMA%20SDK/
-
DISTNAME= lzma${PORTVERSION:S/.//g}
MAINTAINER= bf@FreeBSD.org
@@ -24,7 +23,6 @@ USE_DOS2UNIX= yes
BUILD_WRKSRC= ${WRKSRC}/CPP/7zip/Bundles/LzmaCon
MAKEFILE= makefile.gcc
PLIST_FILES= bin/${PORTNAME}
-CFLAGS+= -D_LZMA_SYSTEM_SIZE_T
.ifdef(WITH_LZMA_PROB32)
#increase the speed of decoding on some 32-bit CPUs, at the expense of doubled
#memory usage for CLzmaDec::probs
@@ -39,6 +37,9 @@ PORTDOCS= 7zC.txt 7zFormat.txt Methods.txt history.txt lzma.txt
post-patch:
@${REINPLACE_CMD} -e '/bool Open(LPCTSTR fileName, DWORD creationDisposition)/,/}/d'\
${WRKSRC}/CPP/7zip/Common/FileStreams.h
+ @${REINPLACE_CMD} -e 's|malloc\.h|stdlib.h|g' \
+ ${WRKSRC}/CPP/7zip/UI/Common/Bench.cpp \
+ ${WRKSRC}/CPP/Common/MyWindows.cpp
@${REINPLACE_CMD} -e \
'/^CXX/d;s|CXX_C|CC|;s|^CFLAGS =|CFLAGS +=|;s|-o|${CFLAGS} -o|'\
${BUILD_WRKSRC}/${MAKEFILE}