aboutsummaryrefslogtreecommitdiff
path: root/archivers/lzop
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-02 22:58:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-02 22:58:15 +0000
commitac5bfb9a2b7a397ec84f912478eedd7cce3115e2 (patch)
tree1c6b62a9ce1aa7f94c7eeb5fecdb9b96b207601a /archivers/lzop
parent2e079a047187710fe8dcb0c5d0be29ff17c167fe (diff)
downloadports-ac5bfb9a2b7a397ec84f912478eedd7cce3115e2.tar.gz
ports-ac5bfb9a2b7a397ec84f912478eedd7cce3115e2.zip
Add lzop, a fast file compressor similar to gzip that uses the LZO lib.
Obtained from: NetBSD
Notes
Notes: svn path=/head/; revision=29123
Diffstat (limited to 'archivers/lzop')
-rw-r--r--archivers/lzop/Makefile22
-rw-r--r--archivers/lzop/distinfo1
-rw-r--r--archivers/lzop/files/patch-aa11
-rw-r--r--archivers/lzop/pkg-comment1
-rw-r--r--archivers/lzop/pkg-descr7
-rw-r--r--archivers/lzop/pkg-plist1
6 files changed, 43 insertions, 0 deletions
diff --git a/archivers/lzop/Makefile b/archivers/lzop/Makefile
new file mode 100644
index 000000000000..d1ff0859dafa
--- /dev/null
+++ b/archivers/lzop/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: lzop
+# Date created: Fri 2 June 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= lzop
+PORTVERSION= 1.00
+CATEGORIES= archivers
+MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/lzo-download/
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/liblzo
+
+GNU_CONFIGURE= YES
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAN1= lzop.1
+
+.include <bsd.port.mk>
diff --git a/archivers/lzop/distinfo b/archivers/lzop/distinfo
new file mode 100644
index 000000000000..4c834e800115
--- /dev/null
+++ b/archivers/lzop/distinfo
@@ -0,0 +1 @@
+MD5 (lzop-1.00.tar.gz) = ef267ac5ea24ccf4ae779f4afb0ab48e
diff --git a/archivers/lzop/files/patch-aa b/archivers/lzop/files/patch-aa
new file mode 100644
index 000000000000..5cf664be1eed
--- /dev/null
+++ b/archivers/lzop/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure Sat Apr 25 12:23:14 1998
++++ configure.new Fri Jun 2 18:55:17 2000
+@@ -2265,7 +2265,7 @@
+ fi
+ done
+
+-for ac_func in access atoi chmod chown fchmod fileno fstat getumask isatty setmode stat umask utime
++for ac_func in access atoi chmod chown fchmod fileno fstat getumask isatty stat umask utime
+ do
+ echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
+ echo "configure:2272: checking for $ac_func" >&5
diff --git a/archivers/lzop/pkg-comment b/archivers/lzop/pkg-comment
new file mode 100644
index 000000000000..f8e83d3734b4
--- /dev/null
+++ b/archivers/lzop/pkg-comment
@@ -0,0 +1 @@
+Fast file compressor similar to gzip, using the LZO library
diff --git a/archivers/lzop/pkg-descr b/archivers/lzop/pkg-descr
new file mode 100644
index 000000000000..1af4058abf99
--- /dev/null
+++ b/archivers/lzop/pkg-descr
@@ -0,0 +1,7 @@
+ lzop is a file compressor which is very similar to gzip. It uses the LZO
+library for compression services and its main advantages over gzip are much
+higher compression and decompression speed (at the cost of some compression
+ratio).
+
+ lzop is distributed under the terms of the GNU General Public License
+(GPL).
diff --git a/archivers/lzop/pkg-plist b/archivers/lzop/pkg-plist
new file mode 100644
index 000000000000..3199c4ec7237
--- /dev/null
+++ b/archivers/lzop/pkg-plist
@@ -0,0 +1 @@
+bin/lzop