aboutsummaryrefslogtreecommitdiff
path: root/archivers/maxcso/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2018-11-08 23:19:03 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2018-11-08 23:19:03 +0000
commit7270e4860f3f46d8ff284179061c3d68292930e4 (patch)
tree932950adeb16f3c4479903d84d5486f0a78a548d /archivers/maxcso/Makefile
parent4c4f74caff8909cbdf65115d3bd83d08f28495c8 (diff)
downloadports-7270e4860f3f46d8ff284179061c3d68292930e4.tar.gz
ports-7270e4860f3f46d8ff284179061c3d68292930e4.zip
Notes
Diffstat (limited to 'archivers/maxcso/Makefile')
-rw-r--r--archivers/maxcso/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/archivers/maxcso/Makefile b/archivers/maxcso/Makefile
new file mode 100644
index 000000000000..5cac13f0cda2
--- /dev/null
+++ b/archivers/maxcso/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= maxcso
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.10.0
+CATEGORIES= archivers
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Fast ISO to CSO compressor for PSP and PS2 emulators
+
+LICENSE= ISCL
+
+LIB_DEPENDS= libuv.so:devel/libuv \
+ liblz4.so:archivers/liblz4 \
+ libzopfli.so:archivers/zopfli
+
+USES= gmake pkgconfig compiler:c++11-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= unknownbrackets
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>