aboutsummaryrefslogtreecommitdiff
path: root/archivers/mscompress
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-05-07 13:20:58 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-05-07 13:20:58 +0000
commit07017fc58342b9372df53e3155abe5c12231b1b0 (patch)
tree0d6aeb81e1bfc08a10d9aa38b059b01aa7a5a32b /archivers/mscompress
parent9567f89a98d7ca5c8a21ad66556c6986ad74671c (diff)
downloadports-07017fc58342b9372df53e3155abe5c12231b1b0.tar.gz
ports-07017fc58342b9372df53e3155abe5c12231b1b0.zip
New port: mscompress, a Microsoft "compress.exe/expand.exe"
compatible (de)compressor PR: 18027 Submitted by: Patrick Seal <patseal@hyperhost.net>
Notes
Notes: svn path=/head/; revision=28333
Diffstat (limited to 'archivers/mscompress')
-rw-r--r--archivers/mscompress/Makefile26
-rw-r--r--archivers/mscompress/distinfo1
-rw-r--r--archivers/mscompress/pkg-comment1
-rw-r--r--archivers/mscompress/pkg-descr9
-rw-r--r--archivers/mscompress/pkg-plist2
5 files changed, 39 insertions, 0 deletions
diff --git a/archivers/mscompress/Makefile b/archivers/mscompress/Makefile
new file mode 100644
index 000000000000..b54615986078
--- /dev/null
+++ b/archivers/mscompress/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: mscompress
+# Date created: 15 Apr 2000
+# Whom: Patrick Seal <patseal@hyperhost.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mscompress
+PORTVERSION= 0.3
+CATEGORIES= archivers
+MASTER_SITES= ftp://ftp.penguin.cz/pub/users/mhi/mscompress/
+
+MAINTAINER= patseal@hyperhost.net
+
+USE_BZIP2= yes
+HAS_CONFIGURE= yes
+
+MAN1= mscompress.1 msexpand.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mscompress ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/msexpand ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/mscompress.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/msexpand.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/archivers/mscompress/distinfo b/archivers/mscompress/distinfo
new file mode 100644
index 000000000000..bad923f7e9eb
--- /dev/null
+++ b/archivers/mscompress/distinfo
@@ -0,0 +1 @@
+MD5 (mscompress-0.3.tar.bz2) = e85fe2fb0df95a7a921ecd867933ff89
diff --git a/archivers/mscompress/pkg-comment b/archivers/mscompress/pkg-comment
new file mode 100644
index 000000000000..0558409bf9c9
--- /dev/null
+++ b/archivers/mscompress/pkg-comment
@@ -0,0 +1 @@
+Microsoft "compress.exe/expand.exe" compatible (de)compressor
diff --git a/archivers/mscompress/pkg-descr b/archivers/mscompress/pkg-descr
new file mode 100644
index 000000000000..10da641d8afb
--- /dev/null
+++ b/archivers/mscompress/pkg-descr
@@ -0,0 +1,9 @@
+Microsoft "compress.exe/expand.exe" compatible (de)compressor
+
+This package contains two programs:
+
+msexpand, which decompress files compressed by Microsoft compress.exe utility
+(e.g. Win 3.x installation files)
+
+mscompress, which compress files using LZ77 compression algorithm. Output
+files can be decompressed using Microsoft expand.exe or msexpand(1).
diff --git a/archivers/mscompress/pkg-plist b/archivers/mscompress/pkg-plist
new file mode 100644
index 000000000000..6c9953a7b096
--- /dev/null
+++ b/archivers/mscompress/pkg-plist
@@ -0,0 +1,2 @@
+bin/mscompress
+bin/msexpand