aboutsummaryrefslogtreecommitdiff
path: root/archivers/ocaml-bz2
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-02-25 14:43:45 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-02-25 14:43:45 +0000
commitecb9aba10ac495c84ba9a4736283fe3be2c5de91 (patch)
tree11b5c35589c9a3892817a994cafae6aa15271141 /archivers/ocaml-bz2
parente4934b425255045add2d1104fef4eb01cdd1ed83 (diff)
downloadports-ecb9aba10ac495c84ba9a4736283fe3be2c5de91.tar.gz
ports-ecb9aba10ac495c84ba9a4736283fe3be2c5de91.zip
CamlBZ2 provides OCaml bindings for libbz2 (AKA bzip2), a popular compression
library which typically compresses better (i.e., smaller resulting files) than gzip. Using CamlBZ2 you can read and write compressed "files", where files can be anything offering an in_channel/out_channel abstraction (files, sockets, ...). Also, with CamlBZ2 you can compress and decompress strings in memory using the bzip2 compression algorithm. Author: Olivier Andreu <oandrieu@gmail.com> and Stefano Zacchiroli <zack@upsilon.cc> WWW: http://camlbz2.forge.ocamlcore.org PR: ports/132059 Submitted by: Jaap Boender <jaapb at kerguelen.org>
Notes
Notes: svn path=/head/; revision=229042
Diffstat (limited to 'archivers/ocaml-bz2')
-rw-r--r--archivers/ocaml-bz2/Makefile38
-rw-r--r--archivers/ocaml-bz2/distinfo3
-rw-r--r--archivers/ocaml-bz2/pkg-descr13
3 files changed, 54 insertions, 0 deletions
diff --git a/archivers/ocaml-bz2/Makefile b/archivers/ocaml-bz2/Makefile
new file mode 100644
index 000000000000..9fe6b0fcf0bc
--- /dev/null
+++ b/archivers/ocaml-bz2/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ocaml-bz2
+# Date created: 2009-02-24
+# Whom: Jaap Boender <jaapb@kerguelen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bz2
+PORTVERSION= 0.6.0
+CATEGORIES= archivers
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/72/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= caml${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jaapb@kerguelen.org
+COMMENT= OCaml library to manipulate bz2 files
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+USE_OCAML= yes
+USE_OCAML_LDCONFIG= yes
+USE_OCAML_WASH= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
+
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/ocaml-bz2/distinfo b/archivers/ocaml-bz2/distinfo
new file mode 100644
index 000000000000..25f5f3b20dd8
--- /dev/null
+++ b/archivers/ocaml-bz2/distinfo
@@ -0,0 +1,3 @@
+MD5 (camlbz2-0.6.0.tar.gz) = 7a1cf822b3fe0ef57df4f8ebd86cac99
+SHA256 (camlbz2-0.6.0.tar.gz) = 8154b4e4699c48e14b4dd56cf839a0c10345e9860eb967066be040d432ae7388
+SIZE (camlbz2-0.6.0.tar.gz) = 57771
diff --git a/archivers/ocaml-bz2/pkg-descr b/archivers/ocaml-bz2/pkg-descr
new file mode 100644
index 000000000000..4d7c89a84684
--- /dev/null
+++ b/archivers/ocaml-bz2/pkg-descr
@@ -0,0 +1,13 @@
+CamlBZ2 provides OCaml bindings for libbz2 (AKA bzip2), a popular compression
+library which typically compresses better (i.e., smaller resulting files) than
+gzip.
+
+Using CamlBZ2 you can read and write compressed "files", where files can be
+anything offering an in_channel/out_channel abstraction (files, sockets, ...).
+
+Also, with CamlBZ2 you can compress and decompress strings in memory using the
+bzip2 compression algorithm.
+
+Author: Olivier Andreu <oandrieu@gmail.com> and
+ Stefano Zacchiroli <zack@upsilon.cc>
+WWW: http://camlbz2.forge.ocamlcore.org