aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-Archive-Any
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-03 13:38:21 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-03 13:38:21 +0000
commitcbd010518af37e4864607d8478b20056ee531f4a (patch)
treeb5180f32d7a2b0531ec77d56db561fd47bba116c /archivers/p5-Archive-Any
parent8d2d848a19dbcdf5666c988a52b8fda4508217f6 (diff)
downloadports-cbd010518af37e4864607d8478b20056ee531f4a.tar.gz
ports-cbd010518af37e4864607d8478b20056ee531f4a.zip
Add p5-Archive-Any 0.09.3, single interface to deal with file archives.
PR: ports/102567 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=174373
Diffstat (limited to 'archivers/p5-Archive-Any')
-rw-r--r--archivers/p5-Archive-Any/Makefile37
-rw-r--r--archivers/p5-Archive-Any/distinfo3
-rw-r--r--archivers/p5-Archive-Any/pkg-descr4
-rw-r--r--archivers/p5-Archive-Any/pkg-plist11
4 files changed, 55 insertions, 0 deletions
diff --git a/archivers/p5-Archive-Any/Makefile b/archivers/p5-Archive-Any/Makefile
new file mode 100644
index 000000000000..5154286cfb41
--- /dev/null
+++ b/archivers/p5-Archive-Any/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Archive-Any
+# Date created: 2006-08-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Archive-Any
+PORTVERSION= 0.09.3
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Archive
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-0.093
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Single interface to deal with file archives
+
+RUN_DEPENDS= ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
+ p5-Archive-Tar>=0.22:${PORTSDIR}/archivers/p5-Archive-Tar \
+ p5-Archive-Zip>=1.07:${PORTSDIR}/archivers/p5-Archive-Zip \
+ p5-File-MMagic>=1.27:${PORTSDIR}/devel/p5-File-MMagic \
+ p5-Module-Find>=0.05:${PORTSDIR}/devel/p5-Module-Find
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Archive::Any.3 Archive::Any::Plugin.3 \
+ Archive::Any::Plugin::Tar.3 Archive::Any::Plugin::Zip.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from dependencies
+IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/p5-Archive-Any/distinfo b/archivers/p5-Archive-Any/distinfo
new file mode 100644
index 000000000000..2f30da44dd96
--- /dev/null
+++ b/archivers/p5-Archive-Any/distinfo
@@ -0,0 +1,3 @@
+MD5 (Archive-Any-0.093.tar.gz) = ba6bf97e81669e7e371e35ffa11f83cb
+SHA256 (Archive-Any-0.093.tar.gz) = e59c70802c0d9ca524353bb0fdb34d4d4082e1f118ba2c05e9d04db38b7fc6c3
+SIZE (Archive-Any-0.093.tar.gz) = 18395
diff --git a/archivers/p5-Archive-Any/pkg-descr b/archivers/p5-Archive-Any/pkg-descr
new file mode 100644
index 000000000000..fcaf3ab1212c
--- /dev/null
+++ b/archivers/p5-Archive-Any/pkg-descr
@@ -0,0 +1,4 @@
+This module is a single interface for manipulating different archive
+formats. Tarballs, zip files, etc.
+
+WWW: http://search.cpan.org/dist/Archive-Any/
diff --git a/archivers/p5-Archive-Any/pkg-plist b/archivers/p5-Archive-Any/pkg-plist
new file mode 100644
index 000000000000..bfe2d75d100a
--- /dev/null
+++ b/archivers/p5-Archive-Any/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Any/.packlist
+%%SITE_PERL%%/Archive/Any.pm
+%%SITE_PERL%%/Archive/Any/Plugin.pm
+%%SITE_PERL%%/Archive/Any/Plugin/Tar.pm
+%%SITE_PERL%%/Archive/Any/Plugin/Zip.pm
+@dirrmtry %%SITE_PERL%%/Archive/Any/Plugin
+@dirrmtry %%SITE_PERL%%/Archive/Any
+@dirrmtry %%SITE_PERL%%/Archive
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Any
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive