aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-Archive-Tar/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-03-28 20:45:10 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-03-28 20:45:10 +0000
commit1a9ef9fa6754e0c0f087f4e7a76e65029a75941c (patch)
treee0596dfc5254e65a6f3de0b5eb6d25f4ad08a7d0 /archivers/p5-Archive-Tar/Makefile
parent0804fca67c5eda2be61329599da40c5734b4d634 (diff)
Introduce Perl 5.10.0
Notes
Notes: svn path=/head/; revision=231213
Diffstat (limited to 'archivers/p5-Archive-Tar/Makefile')
-rw-r--r--archivers/p5-Archive-Tar/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/archivers/p5-Archive-Tar/Makefile b/archivers/p5-Archive-Tar/Makefile
index 55998d93c3a8..6d6e0dd7941c 100644
--- a/archivers/p5-Archive-Tar/Makefile
+++ b/archivers/p5-Archive-Tar/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS= p5-IO-Compress-Bzip2>=2.012:${PORTSDIR}/archivers/p5-IO-Compress-Bz
PERL_CONFIGURE= YES
-MAN1= ptardiff.1 ptar.1
MAN3= Archive::Tar.3 Archive::Tar::File.3
OPTIONS= TEXT_DIFF "Text::Diff support for ptardiff" off
@@ -38,4 +37,17 @@ RUN_DEPENDS+= p5-Package-Constants>=0:${PORTSDIR}/devel/p5-Package-Constants
RUN_DEPENDS+= p5-IO-Zlib>=1.01:${PORTSDIR}/archivers/p5-IO-Zlib
.endif
+.if ${PERL_LEVEL} >= 501000
+PLIST_SUB+= EXE_FILES="@comment "
+.else
+PLIST_SUB+= EXE_FILES=""
+MAN1= ptardiff.1 ptar.1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/5.009/5.666/' ${WRKSRC}/Makefile.PL
+.if ${PERL_LEVEL} >= 501000
+ @${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
+.endif
+
.include <bsd.port.post.mk>