aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-Compress-LZW
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:10:53 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-28 03:10:53 +0000
commitb908b799ef74d646ccaf63fa84ad709364f09545 (patch)
treece152ab7384aa931979e42a3ec8b35cd9ff0f4b8 /archivers/p5-Compress-LZW
parente424172144d83a65092b59eef543f5ff20d055d0 (diff)
downloadports-b908b799ef74d646ccaf63fa84ad709364f09545.tar.gz
ports-b908b799ef74d646ccaf63fa84ad709364f09545.zip
Add p5-Compress-LZW 0.01, pure perl implementation of LZW.
PR: ports/100950 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168917
Diffstat (limited to 'archivers/p5-Compress-LZW')
-rw-r--r--archivers/p5-Compress-LZW/Makefile22
-rw-r--r--archivers/p5-Compress-LZW/distinfo3
-rw-r--r--archivers/p5-Compress-LZW/pkg-descr6
-rw-r--r--archivers/p5-Compress-LZW/pkg-plist6
4 files changed, 37 insertions, 0 deletions
diff --git a/archivers/p5-Compress-LZW/Makefile b/archivers/p5-Compress-LZW/Makefile
new file mode 100644
index 000000000000..d000665d12f9
--- /dev/null
+++ b/archivers/p5-Compress-LZW/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Compress-LZW
+# Date created: 2006-07-28
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Compress-LZW
+PORTVERSION= 0.01
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Compress
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Pure perl implementation of LZW
+
+PERL_CONFIGURE= yes
+
+MAN3= Compress::LZW.3
+
+.include <bsd.port.mk>
diff --git a/archivers/p5-Compress-LZW/distinfo b/archivers/p5-Compress-LZW/distinfo
new file mode 100644
index 000000000000..405cb427ce61
--- /dev/null
+++ b/archivers/p5-Compress-LZW/distinfo
@@ -0,0 +1,3 @@
+MD5 (Compress-LZW-0.01.tar.gz) = 7fdd6198f2caf9de276c308f8bd8db70
+SHA256 (Compress-LZW-0.01.tar.gz) = baa1eaaf45b329898fcd5a79af3c468a5a727f944a0fff354f8727f30a72edf0
+SIZE (Compress-LZW-0.01.tar.gz) = 3106
diff --git a/archivers/p5-Compress-LZW/pkg-descr b/archivers/p5-Compress-LZW/pkg-descr
new file mode 100644
index 000000000000..2971e18a9126
--- /dev/null
+++ b/archivers/p5-Compress-LZW/pkg-descr
@@ -0,0 +1,6 @@
+Compress::LZW it a perl implementation of the newly free LZW
+compression algorithm. It defaults to building a 16-bit codeword table,
+but provides the ability to choose a 12-bit table also. Depending on
+the size of your data, the 12-bit table may provide better compression.
+
+WWW: http://search.cpan.org/dist/Compress-LZW/
diff --git a/archivers/p5-Compress-LZW/pkg-plist b/archivers/p5-Compress-LZW/pkg-plist
new file mode 100644
index 000000000000..dde86a60d5d8
--- /dev/null
+++ b/archivers/p5-Compress-LZW/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZW/.packlist
+%%SITE_PERL%%/Compress/LZW.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress/LZW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Compress
+@dirrmtry %%SITE_PERL%%/Compress