aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-IO-Compress
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-09-11 02:59:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-09-11 02:59:05 +0000
commitd84301c86ccfd26b0fd362fe32b797d703fc1262 (patch)
treef87c510a988f3963a08c99c35f5858112df60a42 /archivers/p5-IO-Compress
parent24cb891543225456d6214e03f03562ebc8b651cd (diff)
downloadports-d84301c86ccfd26b0fd362fe32b797d703fc1262.tar.gz
ports-d84301c86ccfd26b0fd362fe32b797d703fc1262.zip
- Do not install bin/zipdetails on systems with Perl 5.16+ (which has IO::Compress::Base 2.044+ in core)
PR: ports/170762 Submitted by: Shane Ambler <FreeBSD@shaneware.biz>
Notes
Notes: svn path=/head/; revision=304079
Diffstat (limited to 'archivers/p5-IO-Compress')
-rw-r--r--archivers/p5-IO-Compress/Makefile18
-rw-r--r--archivers/p5-IO-Compress/pkg-plist2
2 files changed, 16 insertions, 4 deletions
diff --git a/archivers/p5-IO-Compress/Makefile b/archivers/p5-IO-Compress/Makefile
index 04f5e2d308aa..5c5bd745e40d 100644
--- a/archivers/p5-IO-Compress/Makefile
+++ b/archivers/p5-IO-Compress/Makefile
@@ -22,14 +22,12 @@ BUILD_DEPENDS= p5-Compress-Raw-Bzip2>=2.052:${PORTSDIR}/archivers/p5-Compress-Ra
p5-Compress-Raw-Zlib>=2.052:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib
RUN_DEPENDS= p5-Compress-Raw-Bzip2>=2.052:${PORTSDIR}/archivers/p5-Compress-Raw-Bzip2 \
p5-Compress-Raw-Zlib>=2.052:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib
-
TEST_DEPENDS= p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
CONFLICTS= p5-Compress-Zlib-2* p5-IO-Compress-Base-2* p5-IO-Compress-Zlib-2* p5-IO-Compress-Bzip2-2*
PERL_CONFIGURE= yes
-MAN1= zipdetails.1
MAN3= Compress::Zlib.3 \
File::GlobMapper.3 \
IO::Compress::Base.3 \
@@ -48,4 +46,18 @@ MAN3= Compress::Zlib.3 \
IO::Uncompress::RawInflate.3 \
IO::Uncompress::Unzip.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 501600
+PLIST_SUB+= EXE_FILES="@comment "
+.else
+MAN1+= zipdetails.1
+PLIST_SUB+= EXE_FILES=""
+.endif
+
+post-patch:
+.if ${PERL_LEVEL} >= 501600
+ @${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/p5-IO-Compress/pkg-plist b/archivers/p5-IO-Compress/pkg-plist
index d40949e9ca74..707505d4b4a8 100644
--- a/archivers/p5-IO-Compress/pkg-plist
+++ b/archivers/p5-IO-Compress/pkg-plist
@@ -1,4 +1,4 @@
-bin/zipdetails
+%%EXE_FILES%%bin/zipdetails
%%SITE_PERL%%/Compress/Zlib.pm
%%SITE_PERL%%/File/GlobMapper.pm
%%SITE_PERL%%/IO/Compress/Adapter/Bzip2.pm