aboutsummaryrefslogtreecommitdiff
path: root/archivers/packddir
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-04 18:45:44 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-04 18:45:44 +0000
commita219cf83955ee47571f0bc62149fc51c218d54a1 (patch)
treedf53422254a4915ced3a07e53c9b584d508a8c54 /archivers/packddir
parent11f3c5ff3ba922a1fb62e9c82eb6b78381c597bf (diff)
downloadports-a219cf83955ee47571f0bc62149fc51c218d54a1.tar.gz
ports-a219cf83955ee47571f0bc62149fc51c218d54a1.zip
Support stage
Strip binaries Respect DESTDIR Respect CC (this unbreak building on 10+)
Notes
Notes: svn path=/head/; revision=338669
Diffstat (limited to 'archivers/packddir')
-rw-r--r--archivers/packddir/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/archivers/packddir/Makefile b/archivers/packddir/Makefile
index cad282490012..a7bbffcd6730 100644
--- a/archivers/packddir/Makefile
+++ b/archivers/packddir/Makefile
@@ -13,16 +13,15 @@ COMMENT= These trivial utilities can unpack and create PackdDir archives
WRKSRC= ${WRKDIR}/src
-NO_STAGE= yes
-PLIST_FILES= bin/upackddir
-MAN1= upackddir.1
-
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/upackddir \
+ man/man1/upackddir.1.gz
+MAKE_ARGS= CC=${CC}
post-patch:
- ${REINPLACE_CMD} -e 's|$$(DESTDIR)/usr|${PREFIX}|' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|$$(DESTDIR)/usr|$$(DESTDIR)${PREFIX}|' ${WRKSRC}/Makefile
post-install:
- ${INSTALL_MAN} ${WRKSRC}/upackddir.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/upackddir.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/upackddir
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>