aboutsummaryrefslogtreecommitdiff
path: root/archivers/par2cmdline
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2011-06-23 08:37:05 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2011-06-23 08:37:05 +0000
commit3e3d2347d0a3e42dab0b670ca2d1a2158824eeae (patch)
tree306c0fd091cf2f82f1d4ee3583d80c4399c79591 /archivers/par2cmdline
parent2e9446552d58f64e681d499393449c809e98993d (diff)
downloadports-3e3d2347d0a3e42dab0b670ca2d1a2158824eeae.tar.gz
ports-3e3d2347d0a3e42dab0b670ca2d1a2158824eeae.zip
Fix build with clang
Notes
Notes: svn path=/head/; revision=276107
Diffstat (limited to 'archivers/par2cmdline')
-rw-r--r--archivers/par2cmdline/Makefile2
-rw-r--r--archivers/par2cmdline/files/patch-par2fileformat.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/archivers/par2cmdline/Makefile b/archivers/par2cmdline/Makefile
index bac3ff357743..191d75b5f607 100644
--- a/archivers/par2cmdline/Makefile
+++ b/archivers/par2cmdline/Makefile
@@ -7,7 +7,7 @@
PORTNAME= par2cmdline
PORTVERSION= 0.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= archivers
MASTER_SITES= SF/parchive/${PORTNAME}/${PORTVERSION}
diff --git a/archivers/par2cmdline/files/patch-par2fileformat.h b/archivers/par2cmdline/files/patch-par2fileformat.h
new file mode 100644
index 000000000000..8b2a7642cddf
--- /dev/null
+++ b/archivers/par2cmdline/files/patch-par2fileformat.h
@@ -0,0 +1,11 @@
+--- par2fileformat.h.orig 2011-06-23 08:31:37.639455018 +0200
++++ par2fileformat.h 2011-06-23 08:38:29.287362503 +0200
+@@ -84,7 +84,7 @@
+ PACKET_HEADER header;
+ // Body
+ MD5Hash fileid; // MD5hash of file_hash_16k, file_length, file_name
+- FILEVERIFICATIONENTRY entries[];
++ FILEVERIFICATIONENTRY entries[0];
+ } PACKED;
+
+ // The file description packet is used to record the name of the file,