aboutsummaryrefslogtreecommitdiff
path: root/archivers/peazip/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-01-30 22:11:13 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-01-30 22:11:13 +0000
commita78ac4eb9990a0c44bf11bdb522cbe7a3bf3ad45 (patch)
tree8f9016d16db947e0cef35ace15f5a66fd43323f0 /archivers/peazip/Makefile
parent8d7b87d25932583d8d3c37792b2aa8f9dd29c0bf (diff)
downloadports-a78ac4eb9990a0c44bf11bdb522cbe7a3bf3ad45.tar.gz
ports-a78ac4eb9990a0c44bf11bdb522cbe7a3bf3ad45.zip
Notes
Diffstat (limited to 'archivers/peazip/Makefile')
-rw-r--r--archivers/peazip/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/archivers/peazip/Makefile b/archivers/peazip/Makefile
index 9ce4bf3cfffc..fe0f193e8827 100644
--- a/archivers/peazip/Makefile
+++ b/archivers/peazip/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= peazip
-PORTVERSION= 6.5.0
+PORTVERSION= 6.4.1
CATEGORIES= archivers
MASTER_SITES= https://github.com/giorgiotani/PeaZip/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -25,13 +25,13 @@ DOS2UNIX_REGEX= .*\.([txt]|pas|lpi|txt)
LAZARUS_PROJECT_FILES= project_pea.lpi project_peach.lpi project_gwrap.lpi
LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d
LCL_UNITS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}/lcl/units/${BUILDNAME}
-LAZARUS_VER= 1.8.0
+LAZARUS_VER= 1.6.4
LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
ARCHIVER_FILES= #
OPTIONS_DEFINE= 7Z ARC ZPAQ UNACE
OPTIONS_SINGLE= LCL
-OPTIONS_SINGLE_LCL= GTK2 QT4 QT5
+OPTIONS_SINGLE_LCL= GTK2 QT4
7Z_DESC= 7z file archiver support
ARC_DESC= Arc file archiver support
@@ -39,7 +39,6 @@ ZPAQ_DESC= Zpaq file archiver support
UNACE_DESC= Unace file archiver support
GTK2_DESC= Use gtk20 interface
QT4_DESC= Use qt4 interface
-QT5_DESC= Use qt5 interface
OPTIONS_DEFAULT= GTK2 7Z
@@ -58,12 +57,6 @@ LCL_PLATFORM= qt
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt
.endif
-.if ${PORT_OPTIONS:MQT5}
-LIB_DEPENDS+= libQt5Pas.so:x11-toolkits/qt5pas
-LCL_PLATFORM= qt5
-BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt5
-.endif
-
.if ${PORT_OPTIONS:M7Z}
RUN_DEPENDS+= 7z:archivers/p7zip
ARCHIVER_FILES+=7z
@@ -96,9 +89,6 @@ PLIST_SUB+= UNACE=""
PLIST_SUB+= UNACE="@comment "
.endif
-post-patch:
- ${REINPLACE_CMD} 's|GetSelectedNodePath|Path|g' ${WRKSRC}/peach.pas
-
do-build:
.for PROJECT_FILE in ${LAZARUS_PROJECT_FILES}
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \