aboutsummaryrefslogtreecommitdiff
path: root/archivers/php-brotli
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-03-18 20:24:57 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2019-03-18 20:24:57 +0000
commit6dc94a1c8d54d09c0dc3cc62af058a548ca1dbbd (patch)
tree3c9e8adf7ce492f815bce79b29565c985a0911f8 /archivers/php-brotli
parent58eebd2f89b78c4100b139260fff6b1617859e41 (diff)
downloadports-6dc94a1c8d54d09c0dc3cc62af058a548ca1dbbd.tar.gz
ports-6dc94a1c8d54d09c0dc3cc62af058a548ca1dbbd.zip
[NEW PORT] archivers/php-brotli: PHP Extension for Brotli
Brotli is a generic-purpose lossless compression algorithm that compresses data using a combination of a modern variant of the LZ77 algorithm, Huffman coding and 2nd order context modeling, with a compression ratio comparable to the best currently available general-purpose compression methods. It is similar in speed with deflate but offers more dense compression. This is the Brotli Extension for PHP WWW: https://github.com/kjdev/php-ext-brotli PR: 236610 Submitted by: Daniel Shafer <daniel@shafer.cc> Differential_Revision: https://reviews.freebsd.org/D19619
Notes
Notes: svn path=/head/; revision=496204
Diffstat (limited to 'archivers/php-brotli')
-rw-r--r--archivers/php-brotli/Makefile29
-rw-r--r--archivers/php-brotli/distinfo3
-rw-r--r--archivers/php-brotli/pkg-descr9
3 files changed, 41 insertions, 0 deletions
diff --git a/archivers/php-brotli/Makefile b/archivers/php-brotli/Makefile
new file mode 100644
index 000000000000..87a5bb6a2d3b
--- /dev/null
+++ b/archivers/php-brotli/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= brotli
+DISTVERSION= 0.6.2
+CATEGORIES= archivers
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
+
+MAINTAINER= daniel@shafer.cc
+COMMENT= Brotli extension for PHP
+
+LICENSE= MIT
+
+BUILD_DEPENDS= re2c>0:devel/re2c
+LIB_DEPENDS= libbrotlienc.so:archivers/brotli
+
+USES= dos2unix libtool php:ext pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= kjdev
+GH_PROJECT= php-ext-brotli
+
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libbrotli
+
+PHP_MODNAME= brotli
+
+.include <bsd.port.mk>
diff --git a/archivers/php-brotli/distinfo b/archivers/php-brotli/distinfo
new file mode 100644
index 000000000000..453c99c8abe2
--- /dev/null
+++ b/archivers/php-brotli/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1552932530
+SHA256 (kjdev-php-ext-brotli-0.6.2_GH0.tar.gz) = 8f2d816177f00a784af7afcc6e04b41a8ce4f42725a57130bf5d9682715016d5
+SIZE (kjdev-php-ext-brotli-0.6.2_GH0.tar.gz) = 10043
diff --git a/archivers/php-brotli/pkg-descr b/archivers/php-brotli/pkg-descr
new file mode 100644
index 000000000000..d0c3355603f5
--- /dev/null
+++ b/archivers/php-brotli/pkg-descr
@@ -0,0 +1,9 @@
+Brotli is a generic-purpose lossless compression algorithm that compresses
+data using a combination of a modern variant of the LZ77 algorithm, Huffman
+coding and 2nd order context modeling, with a compression ratio comparable
+to the best currently available general-purpose compression methods. It is
+similar in speed with deflate but offers more dense compression.
+
+This is the Brotli Extension for PHP
+
+WWW: https://github.com/kjdev/php-ext-brotli