aboutsummaryrefslogtreecommitdiff
path: root/archivers/php74-zlib
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2019-09-20 12:21:11 +0000
commit7aca2531e2d785929c4477143e265a8d9b0b516b (patch)
tree5eb143508ff1769e64395b54d8a3b09e1576fba0 /archivers/php74-zlib
parent2a5ef470852066fb4e7c665bc1bb5be0b206d82b (diff)
downloadports-7aca2531e2d785929c4477143e265a8d9b0b516b.tar.gz
ports-7aca2531e2d785929c4477143e265a8d9b0b516b.zip
Welcome PHP 7.4 RC 1 in the ports-tree.
There are many greater changes including: - New module ffi - Remove interbase module - Remove recode module - Remove wddx module - Many modules changes the build switches - Many modules changes the config format, so patches needed to be recreated Special thanks to tobik and ale for their support. Reviewed by: tobik, ale, joneum Sponsored by: PHP Update Service Differential Revision: https://reviews.freebsd.org/D21349
Notes
Notes: svn path=/head/; revision=512406
Diffstat (limited to 'archivers/php74-zlib')
-rw-r--r--archivers/php74-zlib/Makefile11
-rw-r--r--archivers/php74-zlib/files/patch-zlib.c10
2 files changed, 21 insertions, 0 deletions
diff --git a/archivers/php74-zlib/Makefile b/archivers/php74-zlib/Makefile
new file mode 100644
index 000000000000..08b6de27fef4
--- /dev/null
+++ b/archivers/php74-zlib/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= archivers
+
+MASTERDIR= ${.CURDIR}/../../lang/php74
+
+PKGNAMESUFFIX= -zlib
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/archivers/php74-zlib/files/patch-zlib.c b/archivers/php74-zlib/files/patch-zlib.c
new file mode 100644
index 000000000000..be02c50d1df6
--- /dev/null
+++ b/archivers/php74-zlib/files/patch-zlib.c
@@ -0,0 +1,10 @@
+--- zlib.c.orig 2016-06-21 19:57:08 UTC
++++ zlib.c
+@@ -1480,6 +1480,7 @@ static PHP_MSHUTDOWN_FUNCTION(zlib)
+ /* {{{ PHP_RINIT_FUNCTION */
+ static PHP_RINIT_FUNCTION(zlib)
+ {
++ ZLIBG(output_compression) = 0;
+ ZLIBG(compression_coding) = 0;
+ if (!ZLIBG(handler_registered)) {
+ ZLIBG(output_compression) = ZLIBG(output_compression_default);