aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-lz4/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-25 13:54:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-12-25 13:54:09 +0000
commitabc8b046061f7782d1b88855aad5f27c4bed2d72 (patch)
tree0b7db4080f6c5ead381b9315c122e18422c37609 /archivers/py-lz4/Makefile
parent95017af61f9931aba1d7d4228d164570af0c713c (diff)
downloadports-abc8b046061f7782d1b88855aad5f27c4bed2d72.tar.gz
ports-abc8b046061f7782d1b88855aad5f27c4bed2d72.zip
Update to 0.14.0
Notes
Notes: svn path=/head/; revision=457235
Diffstat (limited to 'archivers/py-lz4/Makefile')
-rw-r--r--archivers/py-lz4/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/archivers/py-lz4/Makefile b/archivers/py-lz4/Makefile
index 539280c51295..8bf6e1710270 100644
--- a/archivers/py-lz4/Makefile
+++ b/archivers/py-lz4/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= lz4
-PORTVERSION= 0.13.0
+PORTVERSION= 0.14.0
CATEGORIES= archivers python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,13 +12,16 @@ COMMENT= Python binding for the LZ4 compression library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${FLAVOR} \
+BUILD_DEPENDS= liblz4>=1.7.5:archivers/liblz4 \
+ ${PYTHON_PKGNAMEPREFIX}pkgconfig>=0:devel/py-pkgconfig@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${FLAVOR}
LIB_DEPENDS= liblz4.so:archivers/liblz4
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}deprecation>=0:devel/py-deprecation@${FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${FLAVOR}
USE_PYTHON= distutils py3kplist
-USES= pkgconfig python
+USES= python
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/_version.so \