aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-lzma
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2007-01-06 09:48:24 +0000
committerErwin Lansing <erwin@FreeBSD.org>2007-01-06 09:48:24 +0000
commit254940072379928de7e5de50e62152dfb4af4585 (patch)
treeeeed131563e748580e8bf90dc9141c1b2bf0abe9 /archivers/py-lzma
parentaf42c67d41e8ea8ce57089c2dd6c86b5a95e1323 (diff)
downloadports-254940072379928de7e5de50e62152dfb4af4585.tar.gz
ports-254940072379928de7e5de50e62152dfb4af4585.zip
Update to 0.3.0
PR: 107266 Submitted by: Li-Wen Hsu <lwhsu@lwhsu.org> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=181617
Diffstat (limited to 'archivers/py-lzma')
-rw-r--r--archivers/py-lzma/Makefile6
-rw-r--r--archivers/py-lzma/distinfo6
-rw-r--r--archivers/py-lzma/files/patch-7zip-LzmaCompatDecode.h13
-rw-r--r--archivers/py-lzma/files/patch-RangeCoderBit.h20
4 files changed, 17 insertions, 28 deletions
diff --git a/archivers/py-lzma/Makefile b/archivers/py-lzma/Makefile
index 67bb94fce900..a464d137089d 100644
--- a/archivers/py-lzma/Makefile
+++ b/archivers/py-lzma/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lzma
-PORTVERSION= 0.0.3
+PORTVERSION= 0.3.0
CATEGORIES= archivers python
MASTER_SITES= http://www.joachim-bauch.de/projects/python/pylzma/releases/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,8 +18,4 @@ COMMENT= Python binding for the LZMA compression library
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-post-patch:
- ${FIND} ${WRKSRC} -name '*.cpp' -or -name '*.c' -or \
- -name '*.h' | ${XARGS} -n1 ${REINPLACE_CMD} 's/ //g'
-
.include <bsd.port.mk>
diff --git a/archivers/py-lzma/distinfo b/archivers/py-lzma/distinfo
index 80bef6e9770e..00a57ec106fc 100644
--- a/archivers/py-lzma/distinfo
+++ b/archivers/py-lzma/distinfo
@@ -1,3 +1,3 @@
-MD5 (pylzma-0.0.3.tar.gz) = 312416b2cdf6f4b82ec8fc7a816f74a4
-SHA256 (pylzma-0.0.3.tar.gz) = 015849140788bb8d3f8ddbee3d7f626d9854a342fc1f541ff7f9f297eaa63038
-SIZE (pylzma-0.0.3.tar.gz) = 73057
+MD5 (pylzma-0.3.0.tar.gz) = 7ab1a1706cf3e19f2d10579d795babf7
+SHA256 (pylzma-0.3.0.tar.gz) = 3c110341150bcff08cbe46f9236bb10a71ce00bebd626cb08327af148c03921c
+SIZE (pylzma-0.3.0.tar.gz) = 117440
diff --git a/archivers/py-lzma/files/patch-7zip-LzmaCompatDecode.h b/archivers/py-lzma/files/patch-7zip-LzmaCompatDecode.h
new file mode 100644
index 000000000000..e6b32643a65e
--- /dev/null
+++ b/archivers/py-lzma/files/patch-7zip-LzmaCompatDecode.h
@@ -0,0 +1,13 @@
+--- 7zip/LzmaCompatDecode.h.orig Thu Dec 28 06:27:50 2006
++++ 7zip/LzmaCompatDecode.h Thu Dec 28 06:27:56 2006
+@@ -39,10 +39,6 @@
+ # define LZMACALL
+ #endif
+
+-#ifndef malloc
+-#include <malloc.h>
+-#endif
+-
+ #ifndef UInt32
+ #ifdef _LZMA_UINT32_IS_ULONG
+ #define UInt32 unsigned long
diff --git a/archivers/py-lzma/files/patch-RangeCoderBit.h b/archivers/py-lzma/files/patch-RangeCoderBit.h
deleted file mode 100644
index eb527eddfa7b..000000000000
--- a/archivers/py-lzma/files/patch-RangeCoderBit.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- 7zip/7zip/Compress/LZMA/../RangeCoder/RangeCoderBit.h.orig Wed Apr 28 07:17:33 2004
-+++ 7zip/7zip/Compress/LZMA/../RangeCoder/RangeCoderBit.h Sat Aug 14 14:30:03 2004
-@@ -38,6 +38,8 @@
- UINT32 Probability;
- void UpdateModel(UINT32 symbol)
- {
-+#define Probability (this->Probability)
-+#define UpdateModel (this->UpdateModel)
- /*
- Probability -= (Probability + ((symbol - 1) & ((1 << aNumMoveBits) - 1))) >> aNumMoveBits;
- Probability += (1 - symbol) << (kNumBitModelTotalBits - aNumMoveBits);
-@@ -100,6 +102,8 @@
- }
- }
- };
-+#undef Probability
-+#undef UpdateModel
-
- }}
-