aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-zstandard/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-11 18:00:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-11 18:00:51 +0000
commit0cfc1b9ab4b0aacb97f8b7d32435dd936303e684 (patch)
treeecdcae5c2fade91438a8a3bbcfcf43e95a293ee7 /archivers/py-zstandard/Makefile
parent56dac58885e7bad33cf0bac8c65fc4d8704d757a (diff)
downloadports-0cfc1b9ab4b0aacb97f8b7d32435dd936303e684.tar.gz
ports-0cfc1b9ab4b0aacb97f8b7d32435dd936303e684.zip
archivers/py-zstandard: Fix the run-time failure
Their testsuite falsely succeeds when the installed package actually breaks. Reported to the upstream. Reported by: amdmi3
Notes
Notes: svn path=/head/; revision=561240
Diffstat (limited to 'archivers/py-zstandard/Makefile')
-rw-r--r--archivers/py-zstandard/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/archivers/py-zstandard/Makefile b/archivers/py-zstandard/Makefile
index a606ebd0a069..8bfad7798ce9 100644
--- a/archivers/py-zstandard/Makefile
+++ b/archivers/py-zstandard/Makefile
@@ -2,6 +2,7 @@
PORTNAME= zstandard
DISTVERSION= 0.15.1
+PORTREVISION= 1
CATEGORIES= archivers python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,9 +20,12 @@ LIB_DEPENDS= libzstd.so:archivers/zstd
USES= localbase python:3.6+
USE_PYTHON= distutils autoplist
-PYDISTUTILS_BUILDARGS= --system-zstd
+#PYDISTUTILS_BUILDARGS= --system-zstd # breaks in runtime due to version mismatch, keep disabled until this is fixed: https://github.com/indygreg/python-zstandard/issues/132
post-install:
@cd ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/zstandard && ${STRIP_CMD} backend_c.so _cffi.so
+do-test: # runs the internal testsuite, tests are unreliable or faulty: https://github.com/indygreg/python-zstandard/issues/133
+ @cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} ${PYDISTUTILS_BUILDARGS} test
+
.include <bsd.port.mk>