aboutsummaryrefslogtreecommitdiff
path: root/archivers/quazip/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /archivers/quazip/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
Notes
Diffstat (limited to 'archivers/quazip/Makefile')
-rw-r--r--archivers/quazip/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/archivers/quazip/Makefile b/archivers/quazip/Makefile
index e104a74238ba..3cb4c3500a8c 100644
--- a/archivers/quazip/Makefile
+++ b/archivers/quazip/Makefile
@@ -16,14 +16,16 @@ LICENSE= LGPL21
FLAVORS= qt4 qt5
FLAVOR?= ${FLAVORS:[1]}
-USES= cmake:outsource
+USES= cmake:outsource
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4
-USE_QT4= corelib moc_build network_build qmake_build rcc_build uic_build
+USES+= qt:4
+USE_QT= corelib moc_build network_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=TRUE
. else
-USE_QT5= core buildtools_build qmake_build
+USES+= qt:5
+USE_QT= core buildtools_build qmake_build
CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=FALSE
QTVER_SUFFIX= 5
. endif