aboutsummaryrefslogtreecommitdiff
path: root/archivers/rpm4
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 14:37:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-07-19 14:37:20 +0000
commit4e2de50b4d5eafad06e9238e1264f81c91edb00f (patch)
tree49d7d0359f767808ad630b0f1f31efa866a91ec1 /archivers/rpm4
parent81471a0b2a688eaa10b976b1e7028d5bae6a62fe (diff)
downloadports-4e2de50b4d5eafad06e9238e1264f81c91edb00f.tar.gz
ports-4e2de50b4d5eafad06e9238e1264f81c91edb00f.zip
Enforce libarchive from ports
Notes
Notes: svn path=/head/; revision=392508
Diffstat (limited to 'archivers/rpm4')
-rw-r--r--archivers/rpm4/Makefile12
1 files changed, 3 insertions, 9 deletions
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index f20e12495a53..88bcf72d8b07 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -27,8 +27,8 @@ NLS_USES= gettext
NLS_LIBS= -lintl
PORTDOCS= *
-USES= alias gmake libtool lua:51 pathfix pkgconfig shebangfix \
- tar:bzip2
+USES= alias gmake libarchive libtool lua:51 pathfix pkgconfig \
+ shebangfix tar:bzip2
USE_BDB= 46+
INVALID_BDB_VER=51
GNU_CONFIGURE= yes
@@ -59,12 +59,6 @@ CONFIGURE_ENV+= LUA_CFLAGS=-I${LUA_INCDIR} \
LUA_LIBS="-L${LUA_LIBDIR} -llua-${LUA_VER} -lm"
PLIST_SUB+= VERSION=${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1000000
-LIB_DEPENDS+= libarchive.so.13:${PORTSDIR}/archivers/libarchive
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's:\.\./\.\./bin/::' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's/(hpux)/& || defined(__FreeBSD__)/' \
@@ -77,4 +71,4 @@ post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} librpm/html ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>