aboutsummaryrefslogtreecommitdiff
path: root/archivers/rvm
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-15 07:34:34 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-15 07:34:34 +0000
commited35f851d19c2fcadf0bd140732355cf18384e47 (patch)
tree69bd368b13ab7957855bde497b92894f2468cd39 /archivers/rvm
parent62d1059bd8d79df3b38daffc1c7a5b3db5c042c5 (diff)
downloadports-ed35f851d19c2fcadf0bd140732355cf18384e47.tar.gz
ports-ed35f851d19c2fcadf0bd140732355cf18384e47.zip
add rvm 0.80a
Rsync Vault Manager
Notes
Notes: svn path=/head/; revision=104052
Diffstat (limited to 'archivers/rvm')
-rw-r--r--archivers/rvm/Makefile30
-rw-r--r--archivers/rvm/distinfo2
-rw-r--r--archivers/rvm/pkg-descr11
3 files changed, 43 insertions, 0 deletions
diff --git a/archivers/rvm/Makefile b/archivers/rvm/Makefile
new file mode 100644
index 000000000000..9ba0b2c13919
--- /dev/null
+++ b/archivers/rvm/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection Makefile for: rvm
+# Date created: Mar 15, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rvm
+PORTVERSION= 0.80.a
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.a/-alpha/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Rsync Vault Manager
+
+BUILD_DEPENDS= rsync:${PORTSDIR}/net/rsync
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+
+USE_GNOME= gnometarget
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-default-config-file=${PREFIX}/etc/rvm.conf
+
+PLIST_FILES= bin/rvm
+
+MAN1= rvm.1
+
+.include <bsd.port.mk>
diff --git a/archivers/rvm/distinfo b/archivers/rvm/distinfo
new file mode 100644
index 000000000000..8838a861ce94
--- /dev/null
+++ b/archivers/rvm/distinfo
@@ -0,0 +1,2 @@
+MD5 (rvm-0.80-alpha.tar.gz) = 60c97f5fe46423471317ae5e5cf26fd8
+SIZE (rvm-0.80-alpha.tar.gz) = 193520
diff --git a/archivers/rvm/pkg-descr b/archivers/rvm/pkg-descr
new file mode 100644
index 000000000000..e31e99f51637
--- /dev/null
+++ b/archivers/rvm/pkg-descr
@@ -0,0 +1,11 @@
+RVM is an archive manager that uses rsync to manage backups of multiple
+clients across multiple logical partitions (vaults). It has some features
+that some other rsync-based backup schemes lack, such as being written in
+C++, needing no scripts or other programs than rsync and any binaries on
+which rsync depends (such as SSH), the ability to manage multiple instances
+of rsync connections to separate clients in parallel, the ability to use
+multiple logical partitions (vaults) in a configurable fashion for purporses
+of redundancy and added reliability, and the use of hard links for files that
+have not changed from one archive to the next.
+
+WWW: http://rvm.sourceforge.net/