aboutsummaryrefslogtreecommitdiff
path: root/archivers/snappy-java
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-04 12:58:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-04 12:58:01 +0000
commit6a84798a295d8bb936edb02ed384707a0f0033aa (patch)
tree48fa7b88f5b410a4cf2157dd111870c67fe047a9 /archivers/snappy-java
parentd203ea97be6d3a27e5d2f6e0da1c483c5fa47ea9 (diff)
downloadports-6a84798a295d8bb936edb02ed384707a0f0033aa.tar.gz
ports-6a84798a295d8bb936edb02ed384707a0f0033aa.zip
Simplification and cleanup of the port
Notes
Notes: svn path=/head/; revision=350106
Diffstat (limited to 'archivers/snappy-java')
-rw-r--r--archivers/snappy-java/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/archivers/snappy-java/Makefile b/archivers/snappy-java/Makefile
index 48995aa4a421..3ca80889c6e4 100644
--- a/archivers/snappy-java/Makefile
+++ b/archivers/snappy-java/Makefile
@@ -40,17 +40,14 @@ MAKE_ARGS+= Default_CXX=${CXX}
PLIST_FILES= %%JAVAJARDIR%%/snappy-java.jar lib/libsnappyjava.so
-post-patch-script:
- @${REINPLACE_CMD} -e 's|curl.*||g' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|MVN:=mvn|MVN:=mvn -Dmaven.repo.local=${WRKDIR}/repository --offline|g' \
+post-patch:
+ @${REINPLACE_CMD} -e 's|curl.*||g ; \
+ s|MVN:=mvn|MVN:=mvn -Dmaven.repo.local=${WRKDIR}/repository --offline|g' \
${WRKSRC}/Makefile
-pre-build:
+do-build:
@${MKDIR} ${WRKSRC}/target
@${CP} ${DISTDIR}/snappy-${PORTVERSION:R}.tar.gz ${WRKSRC}/target/
-
-do-build: pre-build
cd ${WRKSRC} && ${SETENV} JAVA_HOME=${JAVA_HOME} \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} && ${LOCALBASE}/share/java/maven3/bin/mvn -Dmaven.repo.local=${WRKDIR}/repository --offline test