aboutsummaryrefslogtreecommitdiff
path: root/archivers/streamvbyte/Makefile
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-05-25 11:25:29 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-05-25 11:25:29 +0000
commitd3973b0392670e7f1383995f40977314868132b1 (patch)
tree6631176ebc46d2e334f864cc653801381ec22262 /archivers/streamvbyte/Makefile
parent678e8b59a73a9bfdbdf8a932b398f2ad1e4577f3 (diff)
downloadports-d3973b0392670e7f1383995f40977314868132b1.tar.gz
ports-d3973b0392670e7f1383995f40977314868132b1.zip
Diffstat (limited to 'archivers/streamvbyte/Makefile')
-rw-r--r--archivers/streamvbyte/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/archivers/streamvbyte/Makefile b/archivers/streamvbyte/Makefile
index de5369a76dcd..57cf78c69ef0 100644
--- a/archivers/streamvbyte/Makefile
+++ b/archivers/streamvbyte/Makefile
@@ -1,6 +1,6 @@
PORTNAME= streamvbyte
DISTVERSIONPREFIX= v
-DISTVERSION= 0.5.2
+DISTVERSION= 1.0.0
CATEGORIES= archivers
MAINTAINER= jwb@FreeBSD.org
@@ -10,17 +10,20 @@ WWW= https://github.com/lemire/streamvbyte
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+# From 0.5.2. Retest with 1.0.0.
BROKEN_powerpc= test fails on big-endian systems
BROKEN_powerpc64= test fails on big-endian systems
USES= cmake
USE_GITHUB= yes
-USE_LDCONFIG= yes
GH_ACCOUNT= lemire
CFLAGS+= -fPIC # For vbz-compression using static lib
+PLIST_FILES= include/streamvbyte.h include/streamvbyte_zigzag.h \
+ include/streamvbytedelta.h lib/libstreamvbyte.a
+
do-test:
cd ${WRKDIR}/.build && ./unit