aboutsummaryrefslogtreecommitdiff
path: root/archivers/stuffit
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-27 12:10:37 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-27 12:10:37 +0000
commit701ab6a48be35a823b6a34cb1fed31071c39ce09 (patch)
tree77d5ff304429710c629373762ccbefb899092e1f /archivers/stuffit
parentd3717695d984365bff5d9280bf3d44c7b84fbf6e (diff)
downloadports-701ab6a48be35a823b6a34cb1fed31071c39ce09.tar.gz
ports-701ab6a48be35a823b6a34cb1fed31071c39ce09.zip
- Pacify portlint and use misc macros
- remove pkg-plist (fastjar and stuffit)
Notes
Notes: svn path=/head/; revision=102286
Diffstat (limited to 'archivers/stuffit')
-rw-r--r--archivers/stuffit/Makefile5
-rw-r--r--archivers/stuffit/pkg-plist2
2 files changed, 3 insertions, 4 deletions
diff --git a/archivers/stuffit/Makefile b/archivers/stuffit/Makefile
index 8d2f9669c56c..9c8e55df213d 100644
--- a/archivers/stuffit/Makefile
+++ b/archivers/stuffit/Makefile
@@ -29,6 +29,7 @@ STRIP= # empty: do not strip linux binary during INSTALL_PROGRAM
WRKSRC= ${WRKDIR}
STUFFIT_FILES= bin/unstuff bin/stuff
STUFFIT_MAN= man/man1/stuff.1 man/man1/unstuff.1
+PLIST_FILES= ${STUFFIT_FILES}
MAN1= stuff.1 unstuff.1
@@ -38,10 +39,10 @@ post-fetch:
do-install:
.for sFile in ${STUFFIT_FILES}
${INSTALL_PROGRAM} ${WRKSRC}/${sFile} ${PREFIX}/bin
- brandelf -t Linux ${PREFIX}/${sFile}
+ ${BRANDELF} -t Linux ${PREFIX}/${sFile}
.endfor
.for mFile in ${STUFFIT_MAN}
- ${INSTALL_MAN} ${WRKSRC}/${mFile} ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${mFile} ${MANPREFIX}/man/man1
.endfor
.include <bsd.port.mk>
diff --git a/archivers/stuffit/pkg-plist b/archivers/stuffit/pkg-plist
deleted file mode 100644
index 52472bdefcf5..000000000000
--- a/archivers/stuffit/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/stuff
-bin/unstuff