aboutsummaryrefslogtreecommitdiff
path: root/archivers/tar-stream-chunker
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-21 14:36:15 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-21 14:36:15 +0000
commit5695de9a69a835a0ff1cbcbbd5250452b15b50f6 (patch)
treea0790a1f427c72da3d49fbd206e5ef5efa532443 /archivers/tar-stream-chunker
parent3f5c9927ad200724eb6e11e119cfe650cbff152b (diff)
downloadports-5695de9a69a835a0ff1cbcbbd5250452b15b50f6.tar.gz
ports-5695de9a69a835a0ff1cbcbbd5250452b15b50f6.zip
Add archivers/tar-stream-chunker
streams stdin of unknown size as a tar to stdout PR: 245748 Submitted by: Igor Ostapenko <igor.ostapenko@pm.me>
Notes
Notes: svn path=/head/; revision=542746
Diffstat (limited to 'archivers/tar-stream-chunker')
-rw-r--r--archivers/tar-stream-chunker/Makefile21
-rw-r--r--archivers/tar-stream-chunker/distinfo3
-rw-r--r--archivers/tar-stream-chunker/pkg-descr13
3 files changed, 37 insertions, 0 deletions
diff --git a/archivers/tar-stream-chunker/Makefile b/archivers/tar-stream-chunker/Makefile
new file mode 100644
index 000000000000..9573c674972b
--- /dev/null
+++ b/archivers/tar-stream-chunker/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= tar-stream-chunker
+PORTVERSION= 1.0.5
+CATEGORIES= archivers
+
+MAINTAINER= igor.ostapenko@pm.me
+COMMENT= Splits stdin of unknown size onto chunks packed as a TAR to stdout
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= ihoro
+
+PLIST_FILES= bin/tar_stream_chunker
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/tar_stream_chunker
+
+.include <bsd.port.mk>
diff --git a/archivers/tar-stream-chunker/distinfo b/archivers/tar-stream-chunker/distinfo
new file mode 100644
index 000000000000..cf2bd0ccb87b
--- /dev/null
+++ b/archivers/tar-stream-chunker/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1587339165
+SHA256 (ihoro-tar-stream-chunker-1.0.5_GH0.tar.gz) = 03aadeefe499bff01ca2207a2e0b48630ea79d2e925edb40f3219318083978f3
+SIZE (ihoro-tar-stream-chunker-1.0.5_GH0.tar.gz) = 6994
diff --git a/archivers/tar-stream-chunker/pkg-descr b/archivers/tar-stream-chunker/pkg-descr
new file mode 100644
index 000000000000..9ca465238f15
--- /dev/null
+++ b/archivers/tar-stream-chunker/pkg-descr
@@ -0,0 +1,13 @@
+Splits stdin of unknown size onto chunks of given size and collects such chunk
+files as a TAR archive what is written to stdout.
+
+Initial motivation was to use it as a packer of a data stream what pipes it to
+https://tarsnap.com for backup purposes, with a requirement of low and more
+predictable memory consumption. And the problem solved here is that TAR file
+header should specify size of a file, but it's unknown due to the nature of
+input data stream.
+
+The following real case could be an example:
+$ pg_dump ... | tar_stream_chunker ... | tarsnap -c ... @-
+
+WWW: https://github.com/ihoro/tar-stream-chunker/