aboutsummaryrefslogtreecommitdiff
path: root/archivers/unace/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-08-12 13:06:26 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-08-12 13:06:26 +0000
commit67c9856a38f57f37468ce46dbd383c782ba007ec (patch)
tree0d2946d4507797a244f92c44deaaf8ebd3355544 /archivers/unace/Makefile
parent062a3010ffa09b617e33b255c27e2fc9d472e2b6 (diff)
downloadports-67c9856a38f57f37468ce46dbd383c782ba007ec.tar.gz
ports-67c9856a38f57f37468ce46dbd383c782ba007ec.zip
Notes
Diffstat (limited to 'archivers/unace/Makefile')
-rw-r--r--archivers/unace/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/archivers/unace/Makefile b/archivers/unace/Makefile
index cb0bc6701239..c73bef4d2936 100644
--- a/archivers/unace/Makefile
+++ b/archivers/unace/Makefile
@@ -20,7 +20,15 @@ USE_GMAKE= yes
ALL_TARGET= clean unace
PLIST_FILES= bin/unace
+post-patch:
+ @${REINPLACE_CMD} -e "s|CFLAGS =|CFLAGS ?=|" \
+ -e "s|CC =|CC ?=|" \
+ -e 's|gcc $$(CFLAGS)|$${CC} $$(CFLAGS)|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's|(CHAR \* s, thead \* head, INT nopath);|(CHAR \* s, thead \* head, INT nopath, unsigned int size);|' \
+ ${WRKSRC}/uac_crt.h
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/unace ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unace ${TARGETDIR}/bin
.include <bsd.port.mk>