aboutsummaryrefslogtreecommitdiff
path: root/archivers/undms
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-03 04:58:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-03 04:58:15 +0000
commit04e0e62a3b6274dfde45943956cabfe283cdb925 (patch)
treece3ed97093d695a581f067100eb7c6607f83face /archivers/undms
parentadb85fb929de0a72a742652dfa9e340ab73e44d9 (diff)
downloadports-04e0e62a3b6274dfde45943956cabfe283cdb925.tar.gz
ports-04e0e62a3b6274dfde45943956cabfe283cdb925.zip
Add undms, a utility that decompresses .dms Amiga disk images to
uncompressed .adf images. Obtained from: NetBSD
Notes
Notes: svn path=/head/; revision=29139
Diffstat (limited to 'archivers/undms')
-rw-r--r--archivers/undms/Makefile30
-rw-r--r--archivers/undms/distinfo3
-rw-r--r--archivers/undms/pkg-comment1
-rw-r--r--archivers/undms/pkg-descr4
-rw-r--r--archivers/undms/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/archivers/undms/Makefile b/archivers/undms/Makefile
new file mode 100644
index 000000000000..dc1a87d74bfe
--- /dev/null
+++ b/archivers/undms/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: undms
+# Date created: Sat 3 June 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= undms
+PORTVERSION= 1.3
+CATEGORIES= archivers
+MASTER_SITES= ftp://de.aminet.net/pub/aminet/misc/unix/ \
+ ftp://us.aminet.net/pub/aminet/misc/unix/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.c
+EXTRACT_SUFX= .Z
+
+MAINTAINER= will@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${GZCAT} ${DISTDIR}/${DISTFILES} > ${WRKDIR}/${DISTNAME}
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o undms undms-1.3.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/undms ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/archivers/undms/distinfo b/archivers/undms/distinfo
new file mode 100644
index 000000000000..335fc363cbaf
--- /dev/null
+++ b/archivers/undms/distinfo
@@ -0,0 +1,3 @@
+$NetBSD: md5,v 1.1.1.1 1999/05/23 19:17:43 tv Exp $
+
+MD5 (undms-1.3.c.Z) = 7c9d5a4830d0e1ded7eab3a287f15c4b
diff --git a/archivers/undms/pkg-comment b/archivers/undms/pkg-comment
new file mode 100644
index 000000000000..cbd397419f81
--- /dev/null
+++ b/archivers/undms/pkg-comment
@@ -0,0 +1 @@
+Converts .dms Amiga disk images to uncompressed .adf images
diff --git a/archivers/undms/pkg-descr b/archivers/undms/pkg-descr
new file mode 100644
index 000000000000..163fd76ec2c5
--- /dev/null
+++ b/archivers/undms/pkg-descr
@@ -0,0 +1,4 @@
+This package includes undms, a decompressor for the Amiga DMS disk image
+format. It outputs ".adf" (11 sector per track, 80 tracks, 512
+bytes/sector) uncompressed disk images which may be written directly to
+disk on NetBSD/amiga or used with an Amiga emulator.
diff --git a/archivers/undms/pkg-plist b/archivers/undms/pkg-plist
new file mode 100644
index 000000000000..a145a16aa938
--- /dev/null
+++ b/archivers/undms/pkg-plist
@@ -0,0 +1 @@
+bin/undms