aboutsummaryrefslogtreecommitdiff
path: root/archivers/unlzx
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-03 04:42:52 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-03 04:42:52 +0000
commit66a77726ffb700e0757150e3646711cb61322b4a (patch)
tree7294e818e4e77bbd91c07198c46c87fabb99728c /archivers/unlzx
parent2db2d50167f50bdd3082fb80bc712ac65cc76aed (diff)
downloadports-66a77726ffb700e0757150e3646711cb61322b4a.tar.gz
ports-66a77726ffb700e0757150e3646711cb61322b4a.zip
Add unlzx, an utility which can extract LZX archives from Amiga systems.
Obtained from: NetBSD
Notes
Notes: svn path=/head/; revision=29137
Diffstat (limited to 'archivers/unlzx')
-rw-r--r--archivers/unlzx/Makefile30
-rw-r--r--archivers/unlzx/distinfo1
-rw-r--r--archivers/unlzx/pkg-comment1
-rw-r--r--archivers/unlzx/pkg-descr2
-rw-r--r--archivers/unlzx/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/archivers/unlzx/Makefile b/archivers/unlzx/Makefile
new file mode 100644
index 000000000000..186416423c68
--- /dev/null
+++ b/archivers/unlzx/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: unlzx
+# Date created: Sat 3 June 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= unlzx
+PORTVERSION= 1.0
+CATEGORIES= archivers
+MASTER_SITES= ftp://de.aminet.net/pub/aminet/misc/unix/ \
+ ftp://us.aminet.net/pub/aminet/misc/unix/
+DISTNAME= ${PORTNAME}.c
+EXTRACT_SUFX= .Z
+
+MAINTAINER= will@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${GZCAT} ${DISTDIR}/${DISTFILES} > ${WRKDIR}/${DISTNAME}
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -o unlzx unlzx.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unlzx ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/unlzx/distinfo b/archivers/unlzx/distinfo
new file mode 100644
index 000000000000..c56f93cce74a
--- /dev/null
+++ b/archivers/unlzx/distinfo
@@ -0,0 +1 @@
+MD5 (unlzx.c.Z) = 897f018f175b0e9f5d2b9d75eadd4fa8
diff --git a/archivers/unlzx/pkg-comment b/archivers/unlzx/pkg-comment
new file mode 100644
index 000000000000..05cd538a3818
--- /dev/null
+++ b/archivers/unlzx/pkg-comment
@@ -0,0 +1 @@
+Extracts .lzx archives from Amiga systems
diff --git a/archivers/unlzx/pkg-descr b/archivers/unlzx/pkg-descr
new file mode 100644
index 000000000000..71ce99c1e099
--- /dev/null
+++ b/archivers/unlzx/pkg-descr
@@ -0,0 +1,2 @@
+This package includes unlzx, an unarchiver for the Amiga LZX file archive
+format.
diff --git a/archivers/unlzx/pkg-plist b/archivers/unlzx/pkg-plist
new file mode 100644
index 000000000000..bd0f51a69e66
--- /dev/null
+++ b/archivers/unlzx/pkg-plist
@@ -0,0 +1 @@
+bin/unlzx