aboutsummaryrefslogtreecommitdiff
path: root/archivers/unmass
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-08-14 15:23:38 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-08-14 15:23:38 +0000
commit6f2095feebf4a78afb4eb3e783323f981335d108 (patch)
tree26b8d49eb2c586b38490e894a339ad7e79c079fb /archivers/unmass
parentcd4a3ea32a27ac097469e46298662980a09e912c (diff)
downloadports-6f2095feebf4a78afb4eb3e783323f981335d108.tar.gz
ports-6f2095feebf4a78afb4eb3e783323f981335d108.zip
Add unmass, a tool to extract game archives such as wad, dar, mea exe's and many
more.
Notes
Notes: svn path=/head/; revision=197673
Diffstat (limited to 'archivers/unmass')
-rw-r--r--archivers/unmass/Makefile37
-rw-r--r--archivers/unmass/distinfo3
-rw-r--r--archivers/unmass/pkg-descr8
3 files changed, 48 insertions, 0 deletions
diff --git a/archivers/unmass/Makefile b/archivers/unmass/Makefile
new file mode 100644
index 000000000000..2d7be3b6dc86
--- /dev/null
+++ b/archivers/unmass/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: unmass
+# Date created: 14 Aug 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unmass
+PORTVERSION= 0.9
+CATEGORIES= archivers
+MASTER_SITES= http://mirex.mypage.sk/FILES/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Extract game archives such as wad, dar, mea exe's and many more
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_DOS2UNIX= yes
+
+MAKE_ENV+= CXX="${CXX}"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/kdev
+
+PLIST_FILES= bin/unmass
+
+post-patch:
+.for f in ma.cpp massfs.h utools.h
+ @${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|' ${WRKSRC}/src/${f}
+.endfor
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}_kdev \
+ ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/archivers/unmass/distinfo b/archivers/unmass/distinfo
new file mode 100644
index 000000000000..7ccb0bbf8317
--- /dev/null
+++ b/archivers/unmass/distinfo
@@ -0,0 +1,3 @@
+MD5 (unmass-0.9.tar.gz) = feba286425d2957b447887bd325af283
+SHA256 (unmass-0.9.tar.gz) = ed3829e4a73592ed3b0628a8ded27b4aec052d39b2083dac5213fcd628054e51
+SIZE (unmass-0.9.tar.gz) = 393735
diff --git a/archivers/unmass/pkg-descr b/archivers/unmass/pkg-descr
new file mode 100644
index 000000000000..b7bb687a61b4
--- /dev/null
+++ b/archivers/unmass/pkg-descr
@@ -0,0 +1,8 @@
+unmass is a tool to extract game archives. It supports the following archive
+types: Crimson Land, Baldur's Gate 2, Civilization 4, Doom (WADs), Dune 2,
+Etherlords 2, Final Fantasy 7 and 8, Flashpoint, Knights of Xentar, Metal Gear
+Solid (DARs), Moorhuhn 2 and 3, Megaman Legends, Oni, Operation Flashpoint,
+Princess Maker 2, Quake 1, RollCage, Swine, Unreal Tournament umods, Virtua
+Fighter bitmaps, MEA exe's, and some economy file formats.
+
+WWW: http://mirex.mypage.sk/index.php?selected=1#Unmass