aboutsummaryrefslogtreecommitdiff
path: root/archivers/unrar-iconv
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-06-07 17:24:26 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-06-07 17:24:26 +0000
commit632767ae3bd136b0b5a7f38f0a46a7f132f990fa (patch)
treea52019ce39d2ee7c706f41a3a6df38ff4c38eeef /archivers/unrar-iconv
parent348e19e5a8dc2f853a4d7dd77cb31921c36c611f (diff)
downloadports-632767ae3bd136b0b5a7f38f0a46a7f132f990fa.tar.gz
ports-632767ae3bd136b0b5a7f38f0a46a7f132f990fa.zip
- Fix build with custom LOCALBASE.
- Fix iconv dependency PR: ports/135326 Submitted by: Yar Odin <yarodin@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=235365
Diffstat (limited to 'archivers/unrar-iconv')
-rw-r--r--archivers/unrar-iconv/Makefile3
-rw-r--r--archivers/unrar-iconv/files/patch-iconv9
2 files changed, 8 insertions, 4 deletions
diff --git a/archivers/unrar-iconv/Makefile b/archivers/unrar-iconv/Makefile
index bd1a660d6e63..a75a5e93b8a0 100644
--- a/archivers/unrar-iconv/Makefile
+++ b/archivers/unrar-iconv/Makefile
@@ -13,6 +13,9 @@ MASTERDIR= ${.CURDIR}/../unrar
EXTRA_PATCHES= ${.CURDIR}/files/patch-iconv
+USE_ICONV= yes
+MAKE_ENV= LOCALBASE="${LOCALBASE}"
+
CONFLICTS= unrar-[0-9]* zh-unrar-[0-9]*
post-install:
diff --git a/archivers/unrar-iconv/files/patch-iconv b/archivers/unrar-iconv/files/patch-iconv
index 7bff2b2ff6dd..81e02a21b033 100644
--- a/archivers/unrar-iconv/files/patch-iconv
+++ b/archivers/unrar-iconv/files/patch-iconv
@@ -123,22 +123,23 @@
+#define MCHelpSwLO "\n lo<option> Encoding option {ignore,translit,<empty>}"
+#define MIconvCannotOpen "\nCannot open iconv to convert between '%s' and '%s' with option '%s'"
+#endif
---- makefile.unix 2008-05-31 14:18:14.000000000 +0800
-+++ makefile.unix 2008-06-27 17:03:22.459952295 +0800
+--- makefile.unix.orig 2008-10-09 17:43:06.000000000 +0400
++++ makefile.unix 2009-06-07 17:27:00.000000000 +0400
@@ -11,6 +11,13 @@
DEFINES=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
STRIP=strip
DESTDIR=/usr
+# iconv stuff. Remove #ICONV# to enable
+# where to get iconv.h
-+CXXFLAGS+= -I/usr/local/include
++CXXFLAGS+= -I$(LOCALBASE)/include
+# where to get libiconv.so*
-+LIBS+= -L/usr/local/lib -liconv
++LIBS+= -L$(LOCALBASE)/lib -liconv
+# enable iconv stuff
+DEFINES+= -DWITH_ICONV
# Linux using LCC
#CXX=lcc
+
--- os.hpp Tue Oct 4 11:57:54 2005
+++ os.hpp Mon Jan 16 18:04:41 2006
@@ -169,6 +169,10 @@