aboutsummaryrefslogtreecommitdiff
path: root/archivers/unzip
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2009-11-06 05:18:58 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2009-11-06 05:18:58 +0000
commit4da8d0e6e0d9ff38d7a65ba8cd50f9773c71ef1d (patch)
tree486c476cd9db5565a01ec0bbf14a8674769e976d /archivers/unzip
parentc59117267d4d588a837afccf90c1d0739fa964a8 (diff)
downloadports-4da8d0e6e0d9ff38d7a65ba8cd50f9773c71ef1d.tar.gz
ports-4da8d0e6e0d9ff38d7a65ba8cd50f9773c71ef1d.zip
For unknown reason bsd.port.mk's eval dislike ( and ) in the path, when
MASTER_SITE_BACKUP with ${MASTER_SITES:S/%SUBDIR%/${MASTER_SITE_SUBDIR}/} at the end and MASTER_SITE_OVERRIDE ?= ${MASTER_SITE_BACKUP} are used together in /etc/make.conf. So, use simple workaround: replace ( and ) by their URL-encoded %-codes. (There is the bug in that area still remains, but not fatal: the combination above don't understand properly ending :tags sometimes and tries mass fetching with ending :tags unstripped. Someone should look at that whole bsd.ports.mk/bsd.sites.mk mess) While I am here, slightly rearrange ending :tags.
Notes
Notes: svn path=/head/; revision=243875
Diffstat (limited to 'archivers/unzip')
-rw-r--r--archivers/unzip/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index bc9cc1c5654d..5ef946c432c1 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -8,9 +8,10 @@
PORTNAME= unzip
PORTVERSION= 6.0
CATEGORIES?= archivers
-MASTER_SITES= SF/infozip/UnZip%206.x%20(latest)/UnZip%20${PORTVERSION} \
- SF/infozip/UnZip%205.x%20and%20earlier/5.51:unreduce
+MASTER_SITES= SF/infozip/UnZip%206.x%20%28latest%29/UnZip%20${PORTVERSION}/:main \
+ SF/infozip/UnZip%205.x%20and%20earlier/5.51/:unreduce
DISTNAME= ${PORTNAME}60
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:main
MAINTAINER?= ache@FreeBSD.org
COMMENT?= List, test and extract compressed files in a ZIP archive
@@ -30,8 +31,8 @@ LOCAL_UNZIP= ${CFLAGS} -DACORN_FTYPE_NFS -DWILD_STOP_AT_DIR \
-DLARGE_FILE_SUPPORT
.if defined(WITH_UNZIP_UNREDUCE)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unreduce_full.zip:unreduce
-EXTRACT_ONLY= ${PORTNAME}60.tar.gz
+DISTFILES+= unreduce_full.zip:unreduce
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
LOCAL_UNZIP+= -DUSE_SMITH_CODE
.endif