aboutsummaryrefslogtreecommitdiff
path: root/archivers/unzip
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2015-02-21 08:46:47 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2015-02-21 08:46:47 +0000
commitf9dda5d3538b906d4c0018589106e5e2eed8833d (patch)
tree53445f2e75529a33615c75078fd1dabbd0d873e7 /archivers/unzip
parentbb28a61584c55fd1a2958f9c4a5ae4cf01eb8f26 (diff)
downloadports-f9dda5d3538b906d4c0018589106e5e2eed8833d.tar.gz
ports-f9dda5d3538b906d4c0018589106e5e2eed8833d.zip
Remove the historic option INSTALL_AS_INFOUNZIP which would install the unzip
binary as info-unzip instead of unzip. Setting this options breaks ports such as java/openjdk7. This could be fixed but the submitter an I don't see a good reason why to keep this option. PR: 197750 Submitted by: amdmi3
Notes
Notes: svn path=/head/; revision=379492
Diffstat (limited to 'archivers/unzip')
-rw-r--r--archivers/unzip/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index d05f1dd6e316..2ed22c605829 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= unzip
PORTVERSION= 6.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= archivers
MASTER_SITES= SF/infozip/UnZip%206.x%20%28latest%29/UnZip%20${PORTVERSION}/:main \
SF/infozip/UnZip%205.x%20and%20earlier/5.51/:unreduce
@@ -21,14 +21,9 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
ALL_TARGET= bsd
MAKEFILE= unix/Makefile
MAKE_ARGS= LF2="${STRIP}"
-.if defined(INSTALL_AS_INFOUNZIP)
-UNZIP_NAME= info-unzip
-.else
-UNZIP_NAME= unzip
-.endif
PORTDOCS= README WHERE
-MANPAGES= ${UNZIP_NAME}.1 funzip.1 unzipsfx.1 zipgrep.1 zipinfo.1
-PLIST_FILES= bin/${UNZIP_NAME} bin/funzip bin/unzipsfx bin/zipgrep \
+MANPAGES= unzip.1 funzip.1 unzipsfx.1 zipgrep.1 zipinfo.1
+PLIST_FILES= bin/unzip bin/funzip bin/unzipsfx bin/zipgrep \
bin/zipinfo
PLIST_FILES+= ${MANPAGES:C|^(.*)\.([1-9])$|man/man\2/\1.\2.gz|}
@@ -88,22 +83,15 @@ CATEGORIES+= russian
EXTRA_PATCHES+= ${FILESDIR}/extra-ru-patch-ebcdic.h
.endif
-.if !defined(INSTALL_AS_INFOUNZIP)
-pre-fetch:
- @${ECHO} ""
- @${ECHO} "Use INSTALL_AS_INFOUNZIP=yes to install Info Unzip as ${PREFIX}/bin/info-unzip"
- @${ECHO} ""
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unzip \
- ${STAGEDIR}${PREFIX}/bin/${UNZIP_NAME}
+ ${STAGEDIR}${PREFIX}/bin
cd ${WRKSRC} && \
${INSTALL_PROGRAM} funzip unzipsfx ${STAGEDIR}${PREFIX}/bin
- ${LN} -sf ${UNZIP_NAME} ${STAGEDIR}${PREFIX}/bin/zipinfo
+ ${LN} -sf unzip ${STAGEDIR}${PREFIX}/bin/zipinfo
${INSTALL_SCRIPT} ${WRKSRC}/unix/zipgrep ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/unzip.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1/${UNZIP_NAME}.1
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
cd ${WRKSRC}/man && ${INSTALL_MAN} ${MANPAGES:Nunzip.1:Ninfo-unzip.1} \
${STAGEDIR}${MAN1PREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${DOCSDIR}