aboutsummaryrefslogtreecommitdiff
path: root/archivers/upx
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2018-12-14 08:44:29 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2018-12-14 08:44:29 +0000
commit6f31554eb6e917fa582767ea8fc89bdad0d0a9d2 (patch)
treeeb187c9ac1d52d94a2cd595c300e61e375299a1e /archivers/upx
parent97020d25d0d412dea5103d6fd2a97231122a83d6 (diff)
downloadports-6f31554eb6e917fa582767ea8fc89bdad0d0a9d2.tar.gz
ports-6f31554eb6e917fa582767ea8fc89bdad0d0a9d2.zip
archivers/upx: Fix build due to missing perl (pod2*) tools
upx unconditionally runs its docs target, which relies on multiple [1] pod2* tools provided by perl. USES=perl and USE_PERL=build were removed in ports r478489, resulting in those tools not being available at build time, and the following errors: /bin/sh: pod2man: not found /bin/sh: pod2html: not found /bin/sh: pod2text: not found This change, accordingly, re-adds perl as an unconditional build dependency, including a comment about what its for. While I'm here: * Update COMMENT for (portlint) compliance [2] [1] pod2man, pod2html, pod2text [2] Wikipedia, MajorGeeks and others also describe UPX without a "The" prefix PR: 234002 Reported by: <mail ozzmosis com> Approved by: portmgr (blanket: build fix, JFI) MFH: 2018Q4 Differential Revision: D18549
Notes
Notes: svn path=/head/; revision=487412
Diffstat (limited to 'archivers/upx')
-rw-r--r--archivers/upx/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/archivers/upx/Makefile b/archivers/upx/Makefile
index 5c85450c44cb..d0fca0fa1694 100644
--- a/archivers/upx/Makefile
+++ b/archivers/upx/Makefile
@@ -7,15 +7,17 @@ DISTVERSION= 3.95
CATEGORIES= archivers
MAINTAINER= fjoe@FreeBSD.org
-COMMENT= The Ultimate Packer for eXecutables
+COMMENT= Ultimate Packer for eXecutables
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libucl.so:archivers/ucl
-USES= gmake
+USES= gmake perl5
USE_GITHUB= yes
+USE_PERL5= build # provides pod2man/pod2html/pod2text required for docs
+
GH_TUPLE= upx:upx-lzma-sdk:${DISTVERSIONPREFIX}${DISTVERSION}:lzma/src/lzma-sdk
MAKE_ENV= UPX_UCLDIR=${LOCALBASE} \