aboutsummaryrefslogtreecommitdiff
path: root/archivers/xarchive/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-10 14:10:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-10 14:10:04 +0000
commit295abdbc9408048ee74ec3d0b1cfac95687e292d (patch)
tree8fd09aecf617c8b448883cb8b31d516068a01488 /archivers/xarchive/Makefile
parent5703f1002380fb5ef2ca6716ef3e35629a0323fe (diff)
downloadports-295abdbc9408048ee74ec3d0b1cfac95687e292d.tar.gz
ports-295abdbc9408048ee74ec3d0b1cfac95687e292d.zip
Notes
Diffstat (limited to 'archivers/xarchive/Makefile')
-rw-r--r--archivers/xarchive/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/archivers/xarchive/Makefile b/archivers/xarchive/Makefile
new file mode 100644
index 000000000000..f2db8e69f9c9
--- /dev/null
+++ b/archivers/xarchive/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: xarchive
+# Date created: 09 November 2005
+# Whom: Mark Kane <mark@mkproductions.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xarchive
+PORTVERSION= 0.2.6.3
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-0.2.6-3
+
+MAINTAINER= mark@mkproductions.org
+COMMENT= A GTK+ front end for archiving tools
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+MAN1= xarchive.1
+
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20
+USE_X_PREFIX= yes
+
+OPTIONS= 7ZIP "Support for 7zip archives" off \
+ ARJ "Support for ARJ archives" off \
+ ACE "Support for ACE archives" off \
+ RAR "Support for RAR archives" off \
+ RPM "Support for RPM archives" off \
+ ZIP "Support for ZIP archives" off
+
+.include <bsd.port.pre.mk>
+
+.if defined (WITH_7ZIP)
+RUN_DEPENDS+= 7z:${PORTSDIR}/archivers/p7zip
+.endif
+
+.if defined (WITH_ARJ)
+RUN_DEPENDS+= arj:${PORTSDIR}/archivers/arj
+.endif
+
+.if defined (WITH_ACE)
+RUN_DEPENDS+= unace:${PORTSDIR}/archivers/unace
+.endif
+
+.if defined (WITH_RAR)
+RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar \
+ unrar:${PORTSDIR}/archivers/unrar
+.endif
+
+.if defined (WITH_RPM)
+RUN_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm4
+.endif
+
+.if defined (WITH_ZIP)
+RUN_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
+ unzip:${PORTSDIR}/archivers/unzip
+.endif
+
+.include <bsd.port.post.mk>