aboutsummaryrefslogtreecommitdiff
path: root/archivers/xdms
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-30 12:32:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-30 12:32:54 +0000
commite59319691830625ac77eaab2443d5a274c5c7286 (patch)
tree26748b0a3c73b3fd5d4fdd6d9ec38ab3d29f0d65 /archivers/xdms
parent1b990319ea4dcc34cb2ca0cab4c7238ce44f811d (diff)
downloadports-e59319691830625ac77eaab2443d5a274c5c7286.tar.gz
ports-e59319691830625ac77eaab2443d5a274c5c7286.zip
Fix build with clang by forcing gnu89
Notes
Notes: svn path=/head/; revision=323960
Diffstat (limited to 'archivers/xdms')
-rw-r--r--archivers/xdms/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/archivers/xdms/Makefile b/archivers/xdms/Makefile
index 214813ed946e..369ad8090403 100644
--- a/archivers/xdms/Makefile
+++ b/archivers/xdms/Makefile
@@ -9,20 +9,26 @@ MASTER_SITES= http://zakalwe.fi/~shd/foss/xdms/
MAINTAINER= sylvio@FreeBSD.org
COMMENT= Tool for decompressing Amiga DMS files
+OPTIONS_DEFINE= DOCS
+
USE_BZIP2= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
ALL_TARGET= xdms
+USE_CSTD= gnu89
+
PORTDOCS= xdms.txt
PLIST_FILES= bin/xdms
+.include <bsd.port.options.mk>
+
post-patch:
${REINPLACE_CMD} "s@-O2 -Wall@$${CFLAGS} -Wall@g" ${WRKSRC}/src/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xdms ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for docs in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}