aboutsummaryrefslogtreecommitdiff
path: root/archivers/zip/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-12 09:59:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-02-12 09:59:54 +0000
commit7b8f1fdf7bcd5aa9e275884a6f24c41761ff0f58 (patch)
tree7c55db62d540b35cc22118889d93fbfeec15cfb9 /archivers/zip/Makefile
parentb28961ffb665e4b01339a26ec7771e0cb421582f (diff)
downloadports-7b8f1fdf7bcd5aa9e275884a6f24c41761ff0f58.tar.gz
ports-7b8f1fdf7bcd5aa9e275884a6f24c41761ff0f58.zip
Notes
Diffstat (limited to 'archivers/zip/Makefile')
-rw-r--r--archivers/zip/Makefile34
1 files changed, 18 insertions, 16 deletions
diff --git a/archivers/zip/Makefile b/archivers/zip/Makefile
index 4208f7a32448..0c7154a2e784 100644
--- a/archivers/zip/Makefile
+++ b/archivers/zip/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: zip
-# Date created: 22 Dec 1994
-# Whom: ache
+# New ports collection makefile for: Info-ZIP
+# Date created: 22 Dec 1994
+# Whom: Andrey Chernov <ache@FreeBSD.org>
#
# $FreeBSD$
#
@@ -9,27 +9,29 @@ PORTNAME= zip
PORTVERSION= 3.0
CATEGORIES= archivers
MASTER_SITES= SF/info${PORTNAME}/Zip%203.x%20%28latest%29/${PORTVERSION}
-DISTFILES= ${PORTNAME}30${EXTRACT_SUFX}
-USE_ZIP= yes
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Create/update ZIP files compatible with pkzip
+COMMENT= Create/update ZIP files compatible with PKZIP
-WRKSRC= ${WRKDIR}/${PORTNAME}30
MAKEFILE= unix/Makefile
ALL_TARGET= generic
-MAN1= zip.1 zipcloak.1 zipnote.1 zipsplit.1
-PLIST_FILES= \
- bin/zip \
- bin/zipcloak \
- bin/zipnote \
- bin/zipsplit
+PLIST_FILES= bin/zip bin/zipcloak bin/zipnote bin/zipsplit
+MAN1= zip.1 zipcloak.1 zipnote.1 zipsplit.1
+PORTDOCS= *
do-install:
-.for file in zip zipcloak zipnote zipsplit
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/${file}.1 ${PREFIX}/man/man1
+.for p in ${PLIST_FILES:T}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${p} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${p}.1 ${MANPREFIX}/man/man1
.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+# License is BSD-based, but not identical, so intall with documentation
+. for d in CHANGES LICENSE README* TODO WHATSNEW WHERE
+ ${INSTALL_DATA} ${WRKSRC}/${d} ${DOCSDIR}
+. endfor
+.endif
.include <bsd.port.mk>