aboutsummaryrefslogtreecommitdiff
path: root/archivers/zopfli
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 16:17:40 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-01-17 16:17:40 +0000
commitadb772280658238005910fb1adcef13963e52b6c (patch)
tree53b9aff6f703ed54e5db6d3492553c608da97078 /archivers/zopfli
parent685f404e7b6f9801ecd9112aa858ea5f97af377b (diff)
downloadports-adb772280658238005910fb1adcef13963e52b6c.tar.gz
ports-adb772280658238005910fb1adcef13963e52b6c.zip
- Add new port archivers/zopfli
Zopfli is a new zlib (gzip, deflate) compatible compressor. This compressor takes more time (~100x slower), but compresses around 5% better than zlib and better than any other zlib-compatible compressor we have found. PR: ports/185680 Submitted by: Alexander Kuehn <freebsd@nagilum.org>
Notes
Notes: svn path=/head/; revision=340066
Diffstat (limited to 'archivers/zopfli')
-rw-r--r--archivers/zopfli/Makefile26
-rw-r--r--archivers/zopfli/distinfo2
-rw-r--r--archivers/zopfli/pkg-descr6
3 files changed, 34 insertions, 0 deletions
diff --git a/archivers/zopfli/Makefile b/archivers/zopfli/Makefile
new file mode 100644
index 000000000000..ed8a3f470bd6
--- /dev/null
+++ b/archivers/zopfli/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alexander Kuehn <freebsd@nagilum.org>
+# $FreeBSD$
+
+PORTNAME= zopfli
+PORTVERSION= 1.0.0
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= freebsd@nagilum.org
+COMMENT= Zopfli Compression Algorithm
+
+LICENSE= APACHE20
+
+PLIST_FILES= bin/zopfli
+
+USE_ZIP= yes
+
+do-build:
+ ${CC} -O2 -W -Wall -Wextra -ansi -pedantic -lm \
+ ${CFLAGS} ${EXTRA_DEFINES} -o ${WRKSRC}/${PORTNAME} \
+ ${WRKSRC}/src/${PORTNAME}/*.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/archivers/zopfli/distinfo b/archivers/zopfli/distinfo
new file mode 100644
index 000000000000..d8b8e18b48fb
--- /dev/null
+++ b/archivers/zopfli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zopfli-1.0.0.zip) = e20d73b56620285e6cce5b510d8e5da6835a81940e48cdf35a69090e666f3adb
+SIZE (zopfli-1.0.0.zip) = 57873
diff --git a/archivers/zopfli/pkg-descr b/archivers/zopfli/pkg-descr
new file mode 100644
index 000000000000..4fd8aa51f2c9
--- /dev/null
+++ b/archivers/zopfli/pkg-descr
@@ -0,0 +1,6 @@
+Zopfli is a new zlib (gzip, deflate) compatible compressor.
+This compressor takes more time (~100x slower), but compresses
+around 5% better than zlib and better than any other zlib-compatible
+compressor we have found.
+
+WWW: http://code.google.com/p/zopfli/