aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-15 20:31:59 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-15 20:31:59 +0000
commit3bbbc67523ef0dd06ece18f655d8794639bf922a (patch)
tree7dc3844ee3ba5b2e377d06041d7af95a7bde0c78 /archivers
parent0f6d454cd3d70efd41fb7435f1dfc4cad5fa8917 (diff)
downloadports-3bbbc67523ef0dd06ece18f655d8794639bf922a.tar.gz
ports-3bbbc67523ef0dd06ece18f655d8794639bf922a.zip
archivers/pear-File_Archive: Change the way *_DEPENDS are set
- Remove BUILD_DEPENDS
Diffstat (limited to 'archivers')
-rw-r--r--archivers/pear-File_Archive/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/archivers/pear-File_Archive/Makefile b/archivers/pear-File_Archive/Makefile
index 3e5f09d3940f..132e162d09d9 100644
--- a/archivers/pear-File_Archive/Makefile
+++ b/archivers/pear-File_Archive/Makefile
@@ -9,23 +9,20 @@ COMMENT= PEAR class to manipulate tar, gz, tgz, bz2, tbz, zip, ar (deb) files
LICENSE= LGPL3
-BUILD_DEPENDS= ${PEARDIR}/MIME/Type.php:mail/pear-MIME_Type@${PHP_FLAVOR}
-RUN_DEPENDS= ${PEARDIR}/MIME/Type.php:mail/pear-MIME_Type@${PHP_FLAVOR}
-
-USES= pear php
-
-NO_ARCH= yes
+RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}MIME_Type>=0:mail/pear-MIME_Type@${PHP_FLAVOR}
+USES= pear
USE_PHP= bz2 pcre zlib
-OPTIONS_DEFINE= PEAR_MAIL PEAR_MAIL_MIME PEAR_CACHE_LITE
+NO_ARCH= yes
+OPTIONS_DEFINE= PEAR_CACHE_LITE PEAR_MAIL PEAR_MAIL_MIME
+PEAR_CACHE_LITE_DESC= PEAR::Cache_Lite support
PEAR_MAIL_DESC= PEAR::Mail support
PEAR_MAIL_MIME_DESC= PEAR::Mail_Mime support
-PEAR_CACHE_LITE_DESC= PEAR::Cache_Lite support
-PEAR_MAIL_RUN_DEPENDS= ${PEARDIR}/Mail.php:mail/pear-Mail@${PHP_FLAVOR}
-PEAR_MAIL_MIME_RUN_DEPENDS= ${PEARDIR}/Mail/mime.php:mail/pear-Mail_Mime@${PHP_FLAVOR}
-PEAR_CACHE_LITE_RUN_DEPENDS+= ${PEARDIR}/Cache/Lite.php:sysutils/pear-Cache_Lite@${PHP_FLAVOR}
+PEAR_CACHE_LITE_RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}Cache_Lite>=1.5.0:sysutils/pear-Cache_Lite@${PHP_FLAVOR}
+PEAR_MAIL_RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}Mail>=0:mail/pear-Mail@${PHP_FLAVOR}
+PEAR_MAIL_MIME_RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}Mail_Mime>=0:mail/pear-Mail_Mime@${PHP_FLAVOR}
.include <bsd.port.mk>