aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-28 18:06:09 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-28 18:06:09 +0000
commit4f127de51926a3a2fcf9a7f1e01f859c4a261837 (patch)
tree8dba05cc580a59bf38fa74fd299b3c9348270cdf /archivers
parent953a2904ad7cb7e009f83961f8f1b657472b5251 (diff)
downloadports-4f127de51926a3a2fcf9a7f1e01f859c4a261837.tar.gz
ports-4f127de51926a3a2fcf9a7f1e01f859c4a261837.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/quazip-qt5/Makefile21
-rw-r--r--archivers/quazip-qt5/distinfo2
-rw-r--r--archivers/quazip-qt5/files/patch-coinstallable_with_qt4_version110
-rw-r--r--archivers/quazip-qt5/pkg-descr4
-rw-r--r--archivers/quazip-qt5/pkg-plist20
6 files changed, 158 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index a7bcd7feb74e..4e00a5d16c63 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -170,6 +170,7 @@
SUBDIR += py-python-snappy
SUBDIR += qpress
SUBDIR += quazip
+ SUBDIR += quazip-qt5
SUBDIR += rar
SUBDIR += rox-archive
SUBDIR += rpm2cpio
diff --git a/archivers/quazip-qt5/Makefile b/archivers/quazip-qt5/Makefile
new file mode 100644
index 000000000000..f8fc04e09049
--- /dev/null
+++ b/archivers/quazip-qt5/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= quazip
+PORTVERSION= 0.7.1
+CATEGORIES= archivers
+MASTER_SITES= SF
+PKGNAMESUFFIX= -qt5
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt/C++ wrapper for ZIP/UNZIP package
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= cmake
+USE_LDCONFIG= yes
+USE_QT5= core buildtools_build qmake_build
+
+CMAKE_ARGS= -DBUILD_WITH_QT4:BOOL=FALSE
+
+.include <bsd.port.mk>
diff --git a/archivers/quazip-qt5/distinfo b/archivers/quazip-qt5/distinfo
new file mode 100644
index 000000000000..3c261ec568b7
--- /dev/null
+++ b/archivers/quazip-qt5/distinfo
@@ -0,0 +1,2 @@
+SHA256 (quazip-0.7.1.tar.gz) = 78c984103555c51e6f7ef52e3a2128e2beb9896871b2cc4d4dbd4d64bff132de
+SIZE (quazip-0.7.1.tar.gz) = 390629
diff --git a/archivers/quazip-qt5/files/patch-coinstallable_with_qt4_version b/archivers/quazip-qt5/files/patch-coinstallable_with_qt4_version
new file mode 100644
index 000000000000..5793b3937c92
--- /dev/null
+++ b/archivers/quazip-qt5/files/patch-coinstallable_with_qt4_version
@@ -0,0 +1,110 @@
+This patch contains several upstream commits that will be part of the 0.7.2
+release that allow the port to be installed together with archivers/quazip (the
+Qt4 version). It works by adding a "5" suffix to the files installed by the Qt5
+version of the port.
+
+------------------------------------------------------------------------
+r252 | alqualos | 2015-01-29 19:04:27 +0100 (Thu, 29 Jan 2015) | 1 line
+
+Link to correct Qt library (patch #23)
+------------------------------------------------------------------------
+r254 | alqualos | 2015-01-29 19:18:07 +0100 (Thu, 29 Jan 2015) | 1 line
+
+Make quazip coinstallable for Qt5 and Qt4 (patch #22)
+------------------------------------------------------------------------
+r255 | alqualos | 2015-01-29 19:22:35 +0100 (Thu, 29 Jan 2015) | 1 line
+
+Fix conflict between patches #23 and #22
+------------------------------------------------------------------------
+r257 | alqualos | 2015-02-06 16:45:25 +0100 (Fri, 06 Feb 2015) | 1 line
+
+Patch #25 (Make devel packages coinstallable too)
+------------------------------------------------------------------------
+
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 250)
++++ CMakeLists.txt (working copy)
+@@ -10,10 +10,11 @@
+
+ if (Qt5Core_FOUND)
+ set(QTCORE_LIBRARIES ${Qt5Core_LIBRARIES})
++ set(QUAZIP_LIB_VERSION_SUFFIX 5)
+ # if there is no QT_ROOT, try to deduce it from Qt QtCore include
+ if ("${QT_ROOT}" STREQUAL "")
+ set(QT_ROOT ${QT_QTCORE_INCLUDE_DIR}/../..)
+- endif()
++ endif()
+ include_directories(${Qt5Core_INCLUDE_DIRS})
+
+ macro(qt_wrap_cpp)
+@@ -48,7 +49,9 @@
+
+ set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)")
+ set(LIB_DESTINATION "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE STRING "Library directory name" FORCE)
++set(QUAZIP_LIB_TARGET_NAME quazip${QUAZIP_LIB_VERSION_SUFFIX} CACHE
++ INTERNAL "Target name of libquazip" FORCE)
+
+ add_subdirectory(quazip)
+
+-install(FILES FindQuaZip.cmake DESTINATION ${CMAKE_ROOT}/Modules)
++install(FILES FindQuaZip.cmake RENAME FindQuaZip${QUAZIP_LIB_VERSION_SUFFIX}.cmake DESTINATION ${CMAKE_ROOT}/Modules)
+Index: FindQuaZip.cmake
+===================================================================
+--- FindQuaZip.cmake (revision 250)
++++ FindQuaZip.cmake (working copy)
+@@ -9,14 +9,17 @@
+ # in cache already
+ SET(QUAZIP_FOUND TRUE)
+ ELSE (QUAZIP_INCLUDE_DIRS AND QUAZIP_LIBRARIES)
++ IF (Qt5Core_FOUND)
++ set(QUAZIP_LIB_VERSION_SUFFIX 5)
++ ENDIF()
+ IF (WIN32)
+ FIND_PATH(QUAZIP_LIBRARY_DIR
+ WIN32_DEBUG_POSTFIX d
+- NAMES libquazip.dll
++ NAMES libquazip${QUAZIP_LIB_VERSION_SUFFIX}.dll
+ HINTS "C:/Programme/" "C:/Program Files"
+ PATH_SUFFIXES QuaZip/lib
+ )
+- FIND_LIBRARY(QUAZIP_LIBRARIES NAMES libquazip.dll HINTS ${QUAZIP_LIBRARY_DIR})
++ FIND_LIBRARY(QUAZIP_LIBRARIES NAMES libquazip${QUAZIP_LIB_VERSION_SUFFIX}.dll HINTS ${QUAZIP_LIBRARY_DIR})
+ FIND_PATH(QUAZIP_INCLUDE_DIR NAMES quazip.h HINTS ${QUAZIP_LIBRARY_DIR}/../ PATH_SUFFIXES include/quazip)
+ FIND_PATH(QUAZIP_ZLIB_INCLUDE_DIR NAMES zlib.h)
+ ELSE(WIN32)
+@@ -25,12 +28,12 @@
+ pkg_check_modules(PC_QUAZIP quazip)
+ FIND_LIBRARY(QUAZIP_LIBRARIES
+ WIN32_DEBUG_POSTFIX d
+- NAMES quazip
++ NAMES quazip${QUAZIP_LIB_VERSION_SUFFIX}
+ HINTS /usr/lib /usr/lib64
+ )
+ FIND_PATH(QUAZIP_INCLUDE_DIR quazip.h
+ HINTS /usr/include /usr/local/include
+- PATH_SUFFIXES quazip
++ PATH_SUFFIXES quazip${QUAZIP_LIB_VERSION_SUFFIX}
+ )
+ FIND_PATH(QUAZIP_ZLIB_INCLUDE_DIR zlib.h HINTS /usr/include /usr/local/include)
+ ENDIF (WIN32)
+Index: quazip/CMakeLists.txt
+===================================================================
+--- quazip/CMakeLists.txt (revision 250)
++++ quazip/CMakeLists.txt (working copy)
+@@ -14,10 +14,10 @@
+ qt_wrap_cpp(MOC_SRCS ${PUBLIC_HEADERS})
+ set(SRCS ${SRCS} ${MOC_SRCS})
+
+-add_library(quazip SHARED ${SRCS})
+-set_target_properties(quazip PROPERTIES VERSION 1.0.0 SOVERSION 1)
++add_library(${QUAZIP_LIB_TARGET_NAME} SHARED ${SRCS})
++set_target_properties(${QUAZIP_LIB_TARGET_NAME} PROPERTIES VERSION 1.0.0 SOVERSION 1)
+ # Link against ZLIB_LIBRARIES if needed (on Windows this variable is empty)
+-target_link_libraries(quazip ${QT_QTMAIN_LIBRARY} ${QT_QTCORE_LIBRARY} ${ZLIB_LIBRARIES})
++target_link_libraries(${QUAZIP_LIB_TARGET_NAME} ${QT_QTMAIN_LIBRARY} ${QTCORE_LIBRARIES} ${ZLIB_LIBRARIES})
+
+-install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip)
+-install(TARGETS quazip LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
++install(FILES ${PUBLIC_HEADERS} DESTINATION include/quazip${QUAZIP_LIB_VERSION_SUFFIX})
++install(TARGETS ${QUAZIP_LIB_TARGET_NAME} LIBRARY DESTINATION ${LIB_DESTINATION} ARCHIVE DESTINATION ${LIB_DESTINATION} RUNTIME DESTINATION ${LIB_DESTINATION})
diff --git a/archivers/quazip-qt5/pkg-descr b/archivers/quazip-qt5/pkg-descr
new file mode 100644
index 000000000000..bdfd86a359cf
--- /dev/null
+++ b/archivers/quazip-qt5/pkg-descr
@@ -0,0 +1,4 @@
+QuaZIP is a simple C++ wrapper over Gilles Vollant's ZIP/UNZIP package that
+can be used to access ZIP archives. It uses the Qt toolkit.
+
+WWW: http://quazip.sourceforge.net/
diff --git a/archivers/quazip-qt5/pkg-plist b/archivers/quazip-qt5/pkg-plist
new file mode 100644
index 000000000000..fe2479007ead
--- /dev/null
+++ b/archivers/quazip-qt5/pkg-plist
@@ -0,0 +1,20 @@
+include/quazip5/JlCompress.h
+include/quazip5/crypt.h
+include/quazip5/ioapi.h
+include/quazip5/quaadler32.h
+include/quazip5/quachecksum32.h
+include/quazip5/quacrc32.h
+include/quazip5/quagzipfile.h
+include/quazip5/quaziodevice.h
+include/quazip5/quazip.h
+include/quazip5/quazip_global.h
+include/quazip5/quazipdir.h
+include/quazip5/quazipfile.h
+include/quazip5/quazipfileinfo.h
+include/quazip5/quazipnewinfo.h
+include/quazip5/unzip.h
+include/quazip5/zip.h
+%%QT_LIBDIR%%/libquazip5.so
+%%QT_LIBDIR%%/libquazip5.so.1
+%%QT_LIBDIR%%/libquazip5.so.1.0.0
+share/cmake/Modules/FindQuaZip5.cmake