aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-31 17:53:03 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-31 17:53:03 +0000
commita7f930c636b101ee81bde870eea72b5be07570dc (patch)
treefd65cf8741ad304e061280fd20d4c3f0c860f385 /archivers
parentf62ba38aa4859ce7cc9c4841853b415d9ed93488 (diff)
downloadports-a7f930c636b101ee81bde870eea72b5be07570dc.tar.gz
ports-a7f930c636b101ee81bde870eea72b5be07570dc.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/p5-Archive-Extract/Makefile31
-rw-r--r--archivers/p5-Archive-Extract/distinfo3
-rw-r--r--archivers/p5-Archive-Extract/pkg-descr9
-rw-r--r--archivers/p5-Archive-Extract/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 518f849566e2..1dbe86a994e4 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -57,6 +57,7 @@
SUBDIR += nulib
SUBDIR += nwreckdum
SUBDIR += orange
+ SUBDIR += p5-Archive-Extract
SUBDIR += p5-Archive-Tar
SUBDIR += p5-Archive-Zip
SUBDIR += p5-Compress-Bzip2
diff --git a/archivers/p5-Archive-Extract/Makefile b/archivers/p5-Archive-Extract/Makefile
new file mode 100644
index 000000000000..50e449e0f171
--- /dev/null
+++ b/archivers/p5-Archive-Extract/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Archive-Extract
+# Date created: 28 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Archive-Extract
+PORTVERSION= 0.08
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Archive
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A generic archive extracting mechanism
+
+BUILD_DEPENDS= ${SITE_PERL}/IPC/Cmd.pm:${PORTSDIR}/devel/p5-IPC-Cmd
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Archive::Extract.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/archivers/p5-Archive-Extract/distinfo b/archivers/p5-Archive-Extract/distinfo
new file mode 100644
index 000000000000..4782286691c0
--- /dev/null
+++ b/archivers/p5-Archive-Extract/distinfo
@@ -0,0 +1,3 @@
+MD5 (Archive-Extract-0.08.tar.gz) = 1e5d21e4dcd52e168eb2d660e44a48a6
+SHA256 (Archive-Extract-0.08.tar.gz) = d8ecd479b37b52384f1521b7fbc6fdca5749638ef9c0903600e0d0748b41c9a1
+SIZE (Archive-Extract-0.08.tar.gz) = 11559
diff --git a/archivers/p5-Archive-Extract/pkg-descr b/archivers/p5-Archive-Extract/pkg-descr
new file mode 100644
index 000000000000..0a9d37bcf14a
--- /dev/null
+++ b/archivers/p5-Archive-Extract/pkg-descr
@@ -0,0 +1,9 @@
+Archive::Extract is a generic archive extraction mechanism.
+
+It allows you to extract any archive file of the type .tar, .tar.gz, .gz
+or .zip without having to worry how it does so, or use different
+interfaces for each type by using either perl modules, or commandline
+tools on your system.
+
+WWW: http://search.cpan.org/dist/Archive-Extract
+Author: Jos Boumans <kane@cpan.org>
diff --git a/archivers/p5-Archive-Extract/pkg-plist b/archivers/p5-Archive-Extract/pkg-plist
new file mode 100644
index 000000000000..735194682339
--- /dev/null
+++ b/archivers/p5-Archive-Extract/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Archive/Extract.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Extract/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive/Extract
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Archive
+@dirrmtry %%SITE_PERL%%/Archive