aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-02 19:43:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-02 19:43:01 +0000
commitdcb77d7cd0a6aab100b84d501e2c1b49d539fc75 (patch)
tree6ecccc19573f8c8b211a3cb0db25b8d3ac35216f /archivers
parent12a2874dac143d311d612075099093db2ccb6a9a (diff)
downloadports-dcb77d7cd0a6aab100b84d501e2c1b49d539fc75.tar.gz
ports-dcb77d7cd0a6aab100b84d501e2c1b49d539fc75.zip
archivers/py-brotlicffi: Add py-brotlicffi 1.0.9.2
BrotliCFFI contains Python CFFI bindings for the reference Brotli encoder/decoder. This allows Python software to use the Brotli compression algorithm directly from Python code. WWW: https://github.com/python-hyper/brotlicffi
Diffstat (limited to 'archivers')
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-brotlicffi/Makefile30
-rw-r--r--archivers/py-brotlicffi/distinfo3
-rw-r--r--archivers/py-brotlicffi/pkg-descr5
4 files changed, 39 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index 7e84fa457cf0..6940e4e2d215 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -168,6 +168,7 @@
SUBDIR += py-acefile
SUBDIR += py-borgbackup
SUBDIR += py-brotli
+ SUBDIR += py-brotlicffi
SUBDIR += py-brotlipy
SUBDIR += py-bz2file
SUBDIR += py-libarchive-c
diff --git a/archivers/py-brotlicffi/Makefile b/archivers/py-brotlicffi/Makefile
new file mode 100644
index 000000000000..5ee0fbcfb4d5
--- /dev/null
+++ b/archivers/py-brotlicffi/Makefile
@@ -0,0 +1,30 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= brotlicffi
+PORTVERSION= 1.0.9.2
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python CFFI bindings to the Brotli library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
+LIB_DEPENDS= libbrotlienc.so:archivers/brotli
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR}
+
+USES= localbase python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+MAKE_ENV= USE_SHARED_BROTLI=1
+
+post-patch:
+ @${RM} -fr ${WRKSRC}/libbrotli/
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/brotlicffi/_brotlicffi*.so
+
+.include <bsd.port.mk>
diff --git a/archivers/py-brotlicffi/distinfo b/archivers/py-brotlicffi/distinfo
new file mode 100644
index 000000000000..4c96df836040
--- /dev/null
+++ b/archivers/py-brotlicffi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1619953881
+SHA256 (brotlicffi-1.0.9.2.tar.gz) = 0c248a68129d8fc6a217767406c731e498c3e19a7be05ea0a90c3c86637b7d96
+SIZE (brotlicffi-1.0.9.2.tar.gz) = 440077
diff --git a/archivers/py-brotlicffi/pkg-descr b/archivers/py-brotlicffi/pkg-descr
new file mode 100644
index 000000000000..cab2eae9805d
--- /dev/null
+++ b/archivers/py-brotlicffi/pkg-descr
@@ -0,0 +1,5 @@
+BrotliCFFI contains Python CFFI bindings for the reference Brotli
+encoder/decoder. This allows Python software to use the Brotli compression
+algorithm directly from Python code.
+
+WWW: https://github.com/python-hyper/brotlicffi