aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 16:53:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-26 16:53:14 +0000
commitf6dbeb2e3579ec67d0731a37818e0dddd6737156 (patch)
tree98cbea4c52a5adea546e733ab26f2d2777910e46 /archivers
parent4229ae707cb51fe664a5d0e0ab2eb55e3b3883ea (diff)
downloadports-f6dbeb2e3579ec67d0731a37818e0dddd6737156.tar.gz
ports-f6dbeb2e3579ec67d0731a37818e0dddd6737156.zip
Notes
Diffstat (limited to 'archivers')
-rw-r--r--archivers/upx/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/archivers/upx/Makefile b/archivers/upx/Makefile
index b3f2ff68eb4e..6b8b25021b80 100644
--- a/archivers/upx/Makefile
+++ b/archivers/upx/Makefile
@@ -14,7 +14,6 @@ COMMENT= The Ultimate Packer for eXecutables
LIB_DEPENDS= libucl.so:${PORTSDIR}/archivers/ucl
-NO_STAGE= yes
LZMA_VER= 4.65
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
USE_BZIP2= yes
@@ -27,15 +26,13 @@ NOT_FOR_ARCHS= sparc64
PORTDOCS= BUGS COPYING LICENSE NEWS PROJECTS README\
README.1ST README.SRC THANKS TODO
-MAN1= upx.1
-PLIST_FILES= bin/upx
+PLIST_FILES= bin/upx \
+ man/man1/upx.1.gz
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/src/upx.out ${PREFIX}/bin/upx
- @${INSTALL_MAN} ${WRKSRC}/doc/upx.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
-.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/upx.out ${STAGEDIR}${PREFIX}/bin/upx
+ @${INSTALL_MAN} ${WRKSRC}/doc/upx.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>