aboutsummaryrefslogtreecommitdiff
path: root/astro/astrometry
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-21 11:56:10 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-11-21 11:56:10 +0000
commit1213e6429af3079ca28ec5a430fc8ce03d676edf (patch)
tree81918ffb4dd9acc89ae936b9a1df4101c92bde66 /astro/astrometry
parent7d98db9cb20bb0c864f384fabe7ad2f4107118a8 (diff)
downloadports-1213e6429af3079ca28ec5a430fc8ce03d676edf.tar.gz
ports-1213e6429af3079ca28ec5a430fc8ce03d676edf.zip
- Fix config pointing into stagedir
- Strip binaries - Add empty dir to plist
Notes
Notes: svn path=/head/; revision=372989
Diffstat (limited to 'astro/astrometry')
-rw-r--r--astro/astrometry/Makefile10
-rw-r--r--astro/astrometry/pkg-plist1
2 files changed, 10 insertions, 1 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 16b39b7291aa..89d065ec3a15 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -3,7 +3,7 @@
PORTNAME= astrometry
PORTVERSION= 0.46
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= astro
MASTER_SITES= http://www.astrometry.net/downloads/
DISTNAME= ${PORTNAME}.net-${PORTVERSION}
@@ -33,4 +33,12 @@ post-patch:
@${REINPLACE_CMD} -e '/CCTEST/s,\\|warning:,,' \
${WRKSRC}/util/makefile.common
+post-install:
+ @${REINPLACE_CMD} -i '' -e 's|${STAGEDIR}||' \
+ ${STAGEDIR}${PREFIX}/${PORTNAME}/etc/${PORTNAME}.cfg
+ @${FIND} ${STAGEDIR}${PREFIX}/${PORTNAME}/bin -type f -not -name "*.py" \
+ -exec ${STRIP_CMD} {} \;
+ @${FIND} ${STAGEDIR}${PREFIX}/${PORTNAME}/lib -type f -name "*.so" \
+ -exec ${STRIP_CMD} {} \;
+
.include <bsd.port.mk>
diff --git a/astro/astrometry/pkg-plist b/astro/astrometry/pkg-plist
index f11c4c0f83f3..c6719a5378be 100644
--- a/astro/astrometry/pkg-plist
+++ b/astro/astrometry/pkg-plist
@@ -257,3 +257,4 @@ astrometry/lib/python/astrometry/util/w3c_validator.py
astrometry/lib/python/astrometry/util/yanny.py
astrometry/ups/astrometry_net.cfg.template
astrometry/ups/astrometry_net.table
+@dir astrometry/data