aboutsummaryrefslogtreecommitdiff
path: root/astro/astrometry
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-10-17 10:44:55 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-10-17 10:44:55 +0000
commitb0329efcb9d9b78f8a7805d2f9c1bea573c19b51 (patch)
tree54489ff15e8d6fca5961f76c40754b0073c9a7b6 /astro/astrometry
parentdca0c3640159e4319cc733eeda925a6cbe508164 (diff)
downloadports-b0329efcb9d9b78f8a7805d2f9c1bea573c19b51.tar.gz
ports-b0329efcb9d9b78f8a7805d2f9c1bea573c19b51.zip
Amend the patch to ensure that all installed shared objects are properly
stripped when needed (should've been part of r514340).
Notes
Notes: svn path=/head/; revision=514656
Diffstat (limited to 'astro/astrometry')
-rw-r--r--astro/astrometry/files/patch-util_Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/astro/astrometry/files/patch-util_Makefile b/astro/astrometry/files/patch-util_Makefile
index 6f08a8fe549b..be9008addd0e 100644
--- a/astro/astrometry/files/patch-util_Makefile
+++ b/astro/astrometry/files/patch-util_Makefile
@@ -1,6 +1,17 @@
--- util/Makefile.orig 2019-04-22 16:25:30 UTC
+++ util/Makefile
-@@ -209,7 +209,9 @@ pyinstall:
+@@ -198,7 +198,9 @@ LINK_DIR := $(PY_BASE_LINK_DIR)/util
+ install: install-core
+ $(MAKE) install-core
+ @echo "The following copy commands may fail; they are optional."
+- -$(MAKE) py && $(CP) _util$(PYTHON_SO_EXT) util.py '$(PY_INSTALL_DIR)'
++ -$(MAKE) py
++ -$(CP) util.py '$(PY_INSTALL_DIR)'
++ -$(BSD_INSTALL_LIB) _util$(PYTHON_SO_EXT) '$(PY_INSTALL_DIR)'
+ @echo ok
+
+ .PHONY: install
+@@ -209,7 +211,9 @@ pyinstall:
echo $(CP) $$x '$(PY_INSTALL_DIR)/'$$x; \
$(CP) $$x '$(PY_INSTALL_DIR)/'$$x; \
done
@@ -11,7 +22,7 @@
.PHONY: pyinstall
-@@ -233,8 +235,8 @@ install-core: $(PYTHON_EXECS) $(PROGS) $(MAIN_PROGS) $
+@@ -233,8 +237,8 @@ install-core: $(PYTHON_EXECS) $(PROGS) $(MAIN_PROGS) $
done
@echo Installing executables into '$(BIN_INSTALL_DIR)'...
@for x in $(PROGS) $(MAIN_PROGS); do \