aboutsummaryrefslogtreecommitdiff
path: root/astro/boinc-astropulse
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-04-16 15:53:32 +0000
committerRene Ladan <rene@FreeBSD.org>2013-04-16 15:53:32 +0000
commit25748307fe638b31fcc8f2253fe9ce6232d08f6c (patch)
treef81d298aa9d6356e4d5e2e6302659aafe2e307a9 /astro/boinc-astropulse
parent76be17ce0f2a7f2ee4f187d9b2e56d4db7996c22 (diff)
downloadports-25748307fe638b31fcc8f2253fe9ce6232d08f6c.tar.gz
ports-25748307fe638b31fcc8f2253fe9ce6232d08f6c.zip
Some cleanups:
- properly use bsd.port.options.mk - remove empty OPTIONS_DEFAULT - no need to support FreeBSD 9.0 anymore, 9.1 is used for cluster builds Feature safe: yes
Notes
Notes: svn path=/head/; revision=315829
Diffstat (limited to 'astro/boinc-astropulse')
-rw-r--r--astro/boinc-astropulse/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index c8f6082b6f06..a1c76fd87141 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -38,16 +38,9 @@ BOINC_CLIENT_GROUP?= nobody
BOINC_CLIENT_HOME?= /var/db/boinc
OPTIONS_DEFINE= X11
-
X11_DESC= Build screensaver (requires net/boinc-client with X11)
-OPTIONS_DEFAULT=
-
-.include <bsd.port.pre.mk>
-# stolen and adapted from bsd.port.mk
-.if ${OSVERSION} >= 900000 && ${OSVERSION} < 900012
-BUILD_DEPENDS+= ${LOCALBASE}/bin/xz:${PORTSDIR}/archivers/xz
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
@@ -106,4 +99,4 @@ post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>