aboutsummaryrefslogtreecommitdiff
path: root/astro/boinc-setiathome
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-12 22:20:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-12 22:20:16 +0000
commitafba0f00f495da207baed7b66585b29124c0c8d9 (patch)
tree5dbdb3d232857330c6112fc05bf9a3c3e4f8886d /astro/boinc-setiathome
parentaf3905f5345b657a59fd1fbb200f0ef0a22bb0c0 (diff)
downloadports-afba0f00f495da207baed7b66585b29124c0c8d9.tar.gz
ports-afba0f00f495da207baed7b66585b29124c0c8d9.zip
- Update to 4.07
PR: ports/73869 Submitted by: J.R. Oldroyd <fbsd@opal.com> (maintainer)
Notes
Notes: svn path=/head/; revision=121485
Diffstat (limited to 'astro/boinc-setiathome')
-rw-r--r--astro/boinc-setiathome/Makefile6
-rw-r--r--astro/boinc-setiathome/distinfo4
-rw-r--r--astro/boinc-setiathome/files/app_info.xml2
-rw-r--r--astro/boinc-setiathome/files/patch-db::db_table.h119
-rw-r--r--astro/boinc-setiathome/files/patch-db::schema_to_class.awk35
-rw-r--r--astro/boinc-setiathome/files/patch-db::sqlblob.h28
-rw-r--r--astro/boinc-setiathome/files/patch-db::xml_util.h11
7 files changed, 6 insertions, 199 deletions
diff --git a/astro/boinc-setiathome/Makefile b/astro/boinc-setiathome/Makefile
index c57047859ba4..916933d5e434 100644
--- a/astro/boinc-setiathome/Makefile
+++ b/astro/boinc-setiathome/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= boinc-setiathome
-PORTVERSION= 4.03
+PORTVERSION= 4.07
CATEGORIES= astro
MASTER_SITES= http://boinc.berkeley.edu/seti_source/nightly/
-DISTNAME= seti_boinc-client-cvs-2004-10-01
+DISTNAME= seti_boinc-client-cvs-2004-11-09
MAINTAINER= fbsd@opal.com
COMMENT= Setiathome for boinc
@@ -20,7 +20,7 @@ LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= LANG=C BOINCDIR=${LOCALBASE}/boinc CPPFLAGS=-I/usr/X11R6/include CFLAGS=-I/usr/X11R6/include LDFLAGS=-L/usr/local/lib
+CONFIGURE_ENV= LANG=C BOINCDIR=${LOCALBASE}/boinc CPPFLAGS=-I${X11BASE}/include CFLAGS=-I${X11BASE}/include LDFLAGS=-L${LOCALBASE}/lib
MAKE_ENV= LANG=C
USE_GMAKE= yes
PKGINSTALL= ${WRKDIR}/pkg-install
diff --git a/astro/boinc-setiathome/distinfo b/astro/boinc-setiathome/distinfo
index d5b835d5b187..d337068e7166 100644
--- a/astro/boinc-setiathome/distinfo
+++ b/astro/boinc-setiathome/distinfo
@@ -1,2 +1,2 @@
-MD5 (seti_boinc-client-cvs-2004-10-01.tar.gz) = 9e4f91cf0bb468da09350da54b98aa7b
-SIZE (seti_boinc-client-cvs-2004-10-01.tar.gz) = 1202532
+MD5 (seti_boinc-client-cvs-2004-11-09.tar.gz) = 4120f1701484b78e099c51adfe31653b
+SIZE (seti_boinc-client-cvs-2004-10-01.tar.gz) = 1214124
diff --git a/astro/boinc-setiathome/files/app_info.xml b/astro/boinc-setiathome/files/app_info.xml
index d4a3d3c8d855..a9a583a2be45 100644
--- a/astro/boinc-setiathome/files/app_info.xml
+++ b/astro/boinc-setiathome/files/app_info.xml
@@ -7,7 +7,7 @@
</file_info>
<app_version>
<app_name>setiathome</app_name>
- <version_num>403</version_num>
+ <version_num>407</version_num>
<file_ref>
<file_name>%%SETI_BINARY%%</file_name>
<main_program/>
diff --git a/astro/boinc-setiathome/files/patch-db::db_table.h b/astro/boinc-setiathome/files/patch-db::db_table.h
deleted file mode 100644
index a56ce6c7d534..000000000000
--- a/astro/boinc-setiathome/files/patch-db::db_table.h
+++ /dev/null
@@ -1,119 +0,0 @@
---- ../db/db_table.h.orig Mon Apr 5 16:03:33 2004
-+++ ../db/db_table.h Sun Oct 3 15:41:31 2004
-@@ -53,6 +53,52 @@
- };
-
- template <typename T>
-+class db_table;
-+
-+template <typename T>
-+std::ostream &operator <<(std::ostream &o, const db_type<T> &a) {
-+ o << a.print_xml();
-+ return o;
-+}
-+
-+template <typename T>
-+std::ostream &operator <<(std::ostream &o, const db_table<T> &a) {
-+ o << a.me->print_xml();
-+ return o;
-+}
-+
-+template <typename T>
-+std::istream &operator >>(std::istream &i, db_table<T> &a) {
-+ std::string s;
-+ std::string s_tag("<");
-+ std::string e_tag("</");
-+ s_tag+=a._search_tag;
-+ e_tag+=a._search_tag;
-+ std::string buffer("");
-+ bool found=false, done=false;
-+ while (!i.eof() && !done) {
-+ i >> s;
-+ if (xml_match_tag(s,s_tag.c_str())) {
-+ found=true;
-+ }
-+ if (found) buffer+=(s+' ');
-+ if (xml_match_tag(s,e_tag.c_str())) {
-+ found=false;
-+ done=true;
-+ }
-+ }
-+ a.me->parse_xml(buffer);
-+ std::string::size_type p=buffer.find(e_tag);
-+ if (p != std::string::npos) {
-+ p=buffer.find('>',p+1);
-+ if (p != std::string::npos) {
-+ i.seekg(p-buffer.size(),std::ios::cur);
-+ }
-+ }
-+ return i;
-+}
-+
-+template <typename T>
- class db_table {
- public:
- db_table(T &t, SQL_CURSOR c);
-@@ -332,12 +378,6 @@
-
- #endif
-
--template <typename T>
--std::ostream &operator <<(std::ostream &o, const db_type<T> &a) {
-- o << a.print_xml();
-- return o;
--}
--
- template <typename T, typename ID_TYPE>
- std::ostream &operator <<(std::ostream &o, const db_reference<T,ID_TYPE> &a) {
- o << a.print_xml();
-@@ -345,12 +385,6 @@
- }
-
- template <typename T>
--std::ostream &operator <<(std::ostream &o, const db_table<T> &a) {
-- o << a.me->print_xml();
-- return o;
--}
--
--template <typename T>
- const char *db_type<T>::search_tag(const char *s) {
- if (s) {
- _search_tag=s;
-@@ -368,37 +402,6 @@
- _search_tag=table_name;
- }
- return _search_tag;
--}
--
--template <typename T>
--std::istream &operator >>(std::istream &i, db_table<T> &a) {
-- std::string s;
-- std::string s_tag("<");
-- std::string e_tag("</");
-- s_tag+=a._search_tag;
-- e_tag+=a._search_tag;
-- std::string buffer("");
-- bool found=false, done=false;
-- while (!i.eof() && !done) {
-- i >> s;
-- if (xml_match_tag(s,s_tag.c_str())) {
-- found=true;
-- }
-- if (found) buffer+=(s+' ');
-- if (xml_match_tag(s,e_tag.c_str())) {
-- found=false;
-- done=true;
-- }
-- }
-- a.me->parse_xml(buffer);
-- std::string::size_type p=buffer.find(e_tag);
-- if (p != std::string::npos) {
-- p=buffer.find('>',p+1);
-- if (p != std::string::npos) {
-- i.seekg(p-buffer.size(),std::ios::cur);
-- }
-- }
-- return i;
- }
-
- template <typename T>
diff --git a/astro/boinc-setiathome/files/patch-db::schema_to_class.awk b/astro/boinc-setiathome/files/patch-db::schema_to_class.awk
deleted file mode 100644
index d54587988295..000000000000
--- a/astro/boinc-setiathome/files/patch-db::schema_to_class.awk
+++ /dev/null
@@ -1,35 +0,0 @@
---- ../db/schema_to_class.awk.orig Thu Sep 30 21:58:31 2004
-+++ ../db/schema_to_class.awk Sun Oct 3 21:45:08 2004
-@@ -344,15 +344,15 @@
- print "\tvoid parse_xml(const std::string &s,const char *tag=\""table"\");" >headerfile
- print " private:\n};\n\n" >headerfile
- if (is_typedef) {
-- print "const char * const db_type<"table">::type_name=\""table"\";" >sourcefile
-- print "const char * db_type<"table">::_search_tag=type_name;" >sourcefile
-- print "const int db_type<"table">::_nfields="nfields-1";" >sourcefile
-- printf("const char * const db_type<%s>::column_names[%d]={",table,nfields-1) >sourcefile
-+ print "template <> const char * const db_type<"table">::type_name=\""table"\";" >sourcefile
-+ print "template <> const char * db_type<"table">::_search_tag=type_name;" >sourcefile
-+ print "template <> const int db_type<"table">::_nfields="nfields-1";" >sourcefile
-+ printf("template <> const char * const db_type<%s>::column_names[%d]={",table,nfields-1) >sourcefile
- } else {
-- print "const char * const db_table<"table">::table_name=\""table"\";" >sourcefile
-- print "const char * db_table<"table">::_search_tag=table_name;" >sourcefile
-- print "const int db_table<"table">::_nfields="nfields-1";" >sourcefile
-- printf("const char * const db_table<%s>::column_names[%d]={",table,nfields-1) >sourcefile
-+ print "template <> const char * const db_table<"table">::table_name=\""table"\";" >sourcefile
-+ print "template <> const char * db_table<"table">::_search_tag=table_name;" >sourcefile
-+ print "template <> const int db_table<"table">::_nfields="nfields-1";" >sourcefile
-+ printf("template <> const char * const db_table<%s>::column_names[%d]={",table,nfields-1) >sourcefile
- }
- for (i=1;i<nfields;i++) printf("\"%s\"%s",fields[i],comma[i]) >sourcefile
- print "};\n" >sourcefile
-@@ -618,7 +618,7 @@
- if (sis_deftype) print "\trv << xml_indent(-2);" > sourcefile
- print "\trv << \"</"fields[i]">\\n\"; " >sourcefile
- } else if (type[i]=="s") {
-- print "\t{\n\t std::string enc_field=xml_encode_string<char>("fields[i]",std::min(strlen("fields[i]"),sizeof("fields[i]")));" > sourcefile
-+ print "\t{\n\t std::string enc_field=xml_encode_string("fields[i]",std::min(strlen("fields[i]"),sizeof("fields[i]")));" > sourcefile
- print "\t rv << xml_indent() << \"<"fields[i]">\";" > sourcefile
- print "\t rv << enc_field << \"</"fields[i]">\\n\";" >sourcefile
- print "\t}" >> sourcefile
diff --git a/astro/boinc-setiathome/files/patch-db::sqlblob.h b/astro/boinc-setiathome/files/patch-db::sqlblob.h
deleted file mode 100644
index 5df9c99f3602..000000000000
--- a/astro/boinc-setiathome/files/patch-db::sqlblob.h
+++ /dev/null
@@ -1,28 +0,0 @@
---- ../db/sqlblob.h.orig Thu Jul 1 13:55:37 2004
-+++ ../db/sqlblob.h Sun Oct 3 17:01:17 2004
-@@ -73,6 +73,12 @@
- }
-
-
-+template <typename T>
-+inline std::string xml_encode_string(const sqlblob<T> &input,
-+ xml_encoding encoding=_x_xml_entity) {
-+ return xml_encode_string(static_cast<const T *>(input),input.size(),encoding);
-+}
-+
-
- template <typename T=unsigned char>
- class sqlblob {
-@@ -123,12 +129,6 @@
- template <typename T>
- std::string sqlblob<T>::print_raw() const {
- return std::string(reinterpret_cast<const char *>(&(*begin())),size());
--}
--
--template <typename T>
--inline std::string xml_encode_string(const sqlblob<T> &input,
-- xml_encoding encoding=_x_xml_entity) {
-- return xml_encode_string(static_cast<const T *>(input),input.size(),encoding);
- }
-
-
diff --git a/astro/boinc-setiathome/files/patch-db::xml_util.h b/astro/boinc-setiathome/files/patch-db::xml_util.h
deleted file mode 100644
index c7f6a32f360a..000000000000
--- a/astro/boinc-setiathome/files/patch-db::xml_util.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../db/xml_util.h.orig Wed Jun 30 16:52:29 2004
-+++ ../db/xml_util.h Sun Oct 3 21:16:22 2004
-@@ -223,7 +223,7 @@
- template <typename T>
- inline std::string xml_encode_string(const std::vector<T> &input,
- xml_encoding encoding=_x_xml_entity) {
-- return xml_encode_string<T>(&(*(input.begin())),input.size(),encoding);
-+ return xml_encode_string(&(*(input.begin())),input.size(),encoding);
- }
-
- #include <cctype>