aboutsummaryrefslogtreecommitdiff
path: root/astro/boinc-setiathome
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-11 22:34:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-11 22:34:12 +0000
commitcef7a5ec00372d85685897bd061e884a5287aeee (patch)
tree096368bfb8938d0861c5dd967fb1e5e2d6f833af /astro/boinc-setiathome
parent2b08f50a06ae4095fd9057cdc34e5bec8c755f48 (diff)
downloadports-cef7a5ec00372d85685897bd061e884a5287aeee.tar.gz
ports-cef7a5ec00372d85685897bd061e884a5287aeee.zip
- Update to 4.07.20050218, with GUI
GUI disabled on 4.x for now PR: ports/79349 Submitted by: J.R. Oldroyd <fbsd@opal.com> (maintainer)
Notes
Notes: svn path=/head/; revision=133103
Diffstat (limited to 'astro/boinc-setiathome')
-rw-r--r--astro/boinc-setiathome/Makefile98
-rw-r--r--astro/boinc-setiathome/distinfo4
-rw-r--r--astro/boinc-setiathome/files/patch-Makefile.incl11
-rw-r--r--astro/boinc-setiathome/files/patch-client::Makefile.in25
-rw-r--r--astro/boinc-setiathome/files/patch-db::schema_to_class.in11
-rw-r--r--astro/boinc-setiathome/files/patch-m4-sah_check_boinc.m451
-rw-r--r--astro/boinc-setiathome/files/patch-m4-sah_header_stdcxx.m411
-rw-r--r--astro/boinc-setiathome/files/patch-m4-sah_largefile_breaks_cxx.m411
-rw-r--r--astro/boinc-setiathome/pkg-install4
-rw-r--r--astro/boinc-setiathome/pkg-plist6
10 files changed, 160 insertions, 72 deletions
diff --git a/astro/boinc-setiathome/Makefile b/astro/boinc-setiathome/Makefile
index 897ba54235c2..3d440d1f1137 100644
--- a/astro/boinc-setiathome/Makefile
+++ b/astro/boinc-setiathome/Makefile
@@ -6,66 +6,106 @@
#
PORTNAME= boinc-setiathome
-PORTVERSION= 4.07
+PORTVERSION= 4.07.20050218
CATEGORIES= astro
-MASTER_SITES= http://boinc.berkeley.edu/seti_source/nightly/
-DISTNAME= seti_boinc-client-cvs-2004-11-09
+MASTER_SITES= http://setiweb.ssl.berkeley.edu/sah/seti_source/nightly/
+DISTNAME= seti_boinc-client-cvs-2005-02-18
MAINTAINER= fbsd@opal.com
COMMENT= Setiathome for boinc
-BUILD_DEPENDS= ${LOCALBASE}/boinc/api/boinc_api.h:${PORTSDIR}/net/boinc-client
-RUN_DEPENDS= boinc-client:${PORTSDIR}/net/boinc-client
-LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
+.include <bsd.port.pre.mk>
-BROKEN= Unfetchable
+# Disable GUI on FreeBSD 4.x until
+# undefined reference to `boinc_init_graphics'
+# is fixed
+.if ${OSVERSION} < 500000
+WITHOUT_X11= yes
+.endif
+
+# Build with "make -DWITHOUT_X11" if you don't want the boincmgr
+# GUI management interface or the "screensaver" status displays
+# from any of the client applications.
+#
+# Defining WITHOUT_X11 removes the dependencies on the X11 libs
+# and the glut and jpeg graphics libs.
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/boinc/boinc-client:${PORTSDIR}/net/boinc-client
+RUN_DEPENDS+= boinc:${PORTSDIR}/net/boinc-client
+LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
+.if !defined(WITHOUT_X11)
+LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg \
+ glut:${PORTSDIR}/graphics/libglut
+USE_XLIB= yes
+.endif
+
+USE_AUTOMAKE_VER= 19
+USE_AUTOCONF_VER= 259
+USE_AUTOHEADER_VER= 259
+USE_LIBTOOL_VER= 15
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= LANG=C BOINCDIR=${LOCALBASE}/boinc CPPFLAGS=-I${X11BASE}/include CFLAGS=-I${X11BASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-server
+.if !defined(WITHOUT_X11)
+CONFIGURE_ARGS+= --disable-dynamic-graphics
+.else
+CONFIGURE_ARGS+= --disable-gui
+.endif
+CONFIGURE_ENV= LANG=C BOINCDIR=${LOCALBASE} CPPFLAGS=-I${X11BASE}/include CXXFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" LDFLAGS=-L${LOCALBASE}/lib
MAKE_ENV= LANG=C
USE_GMAKE= yes
PKGINSTALL= ${WRKDIR}/pkg-install
-WRKSRC= ${WRKDIR}/seti_boinc/client
-CONFIGURE_WRKSRC=${WRKDIR}/seti_boinc/
+WRKSRC= ${WRKDIR}/seti_boinc
+
+FIND_SETI_BINARY=(cd ${WRKSRC}/client; make -V CLIENT_PROG)
+SETI_SITE= setiathome.berkeley.edu
+SETI_BINARY= setiathome
-FIND_SETI_BINARY=(cd ${WRKSRC}; make -V PROG)
-SETI_SITE?= setiathome.berkeley.edu
PLIST_SUB= SETI_SITE=${SETI_SITE} BOINC_HOME=${BOINC_HOME}
+.if !defined(WITHOUT_X11)
+PLIST_SUB+= BOINC_GUI=""
+.else
+PLIST_SUB+= BOINC_GUI="@comment "
+.endif
# these must match settings in ../../net/boinc-client/Makefile
BOINC_USER= boinc
+BOINC_GROUP= nobody
BOINC_HOME= /var/db/boinc
-BOINC_DATADIR= ${PREFIX}/boinc
-# ${TOUCH} ${WRKDIR}/seti_boinc/db/schema_master.cpp
-pre-patch:
- ${TOUCH} ${WRKDIR}/seti_boinc/client/dependencies
- ${TOUCH} ${WRKDIR}/seti_boinc/db/dependencies
+pre-configure:
+ ${TOUCH} ${WRKSRC}/missing
+ cd ${WRKSRC}; ${ACLOCAL} -I ${LOCALBASE}/share/libtool${USE_LIBTOOL_VER}/libltdl -I m4
post-build:
- ${SED} -e "s:%%SETI_BINARY%%:`${FIND_SETI_BINARY}`:g" \
- -e "s:%%SETI_SITE%%:${SETI_SITE}:g" \
- -e "s:%%BOINC_DATADIR%%:${BOINC_DATADIR}:g" \
+ ${SED} -e "s:%%SETI_BINARY%%:${SETI_BINARY}:g" \
< ${FILESDIR}/app_info.xml > ${WRKDIR}/app_info.xml
${SED} -e "s:%%SETI_SITE%%:${SETI_SITE}:g" \
-e "s:%%BOINC_HOME%%:${BOINC_HOME}:g" \
-e "s:%%BOINC_USER%%:${BOINC_USER}:g" \
+ -e "s:%%BOINC_GROUP%%:${BOINC_GROUP}:g" \
< pkg-install > ${WRKDIR}/pkg-install
do-install:
- ${MKDIR} ${PREFIX}/boinc/projects/${SETI_SITE}
- ${INSTALL_PROGRAM} ${WRKSRC}/`${FIND_SETI_BINARY}` ${PREFIX}/boinc/projects/${SETI_SITE}
- ${INSTALL_DATA} ${WRKDIR}/app_info.xml ${PREFIX}/boinc/projects/${SETI_SITE}
- ${MKDIR} ${BOINC_HOME}/projects/${SETI_SITE}/
- ${LN} -s ${PREFIX}/boinc/projects/${SETI_SITE}/`${FIND_SETI_BINARY}` ${BOINC_HOME}/projects/${SETI_SITE}
- ${LN} -s ${PREFIX}/boinc/projects/${SETI_SITE}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/client/`${FIND_SETI_BINARY}` ${PREFIX}/lib/boinc/${SETI_BINARY}
+.if !defined(WITHOUT_X11)
+ #${INSTALL_PROGRAM} ${WRKSRC}/client/`${FIND_SETI_BINARY}`.so ${PREFIX}/lib/boinc/${SETI_BINARY}.so
+.endif
post-install:
+ ${MKDIR} ${BOINC_HOME}/projects/${SETI_SITE}
+ ${INSTALL_DATA} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}
+ ${LN} -s ${PREFIX}/lib/boinc/${SETI_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}
+.if !defined(WITHOUT_X11)
+ #${LN} -s ${PREFIX}/lib/boinc/${SETI_BINARY}.so ${BOINC_HOME}/projects/${SETI_SITE}
+.endif
${REINPLACE_CMD} \
- -e "s:%%SETI_BINARY%%:`${FIND_SETI_BINARY}`:g" \
- -e "s:%%BOINC_HOME%%:${BOINC_HOME}:g" ${TMPPLIST}
+ -e "s:%%SETI_SITE%%:${SETI_SITE}:g" \
+ -e "s:%%SETI_BINARY%%:${SETI_BINARY}:g" \
+ -e "s:%%BOINC_HOME%%:${BOINC_HOME}:g" \
+ ${TMPPLIST}
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/astro/boinc-setiathome/distinfo b/astro/boinc-setiathome/distinfo
index d337068e7166..b25181c351c7 100644
--- a/astro/boinc-setiathome/distinfo
+++ b/astro/boinc-setiathome/distinfo
@@ -1,2 +1,2 @@
-MD5 (seti_boinc-client-cvs-2004-11-09.tar.gz) = 4120f1701484b78e099c51adfe31653b
-SIZE (seti_boinc-client-cvs-2004-10-01.tar.gz) = 1214124
+MD5 (seti_boinc-client-cvs-2005-02-18.tar.gz) = 6f4aa7dc0a88f50bc6f7c160fb3150ef
+SIZE (seti_boinc-client-cvs-2005-02-18.tar.gz) = 1462337
diff --git a/astro/boinc-setiathome/files/patch-Makefile.incl b/astro/boinc-setiathome/files/patch-Makefile.incl
new file mode 100644
index 000000000000..f0a41b292de0
--- /dev/null
+++ b/astro/boinc-setiathome/files/patch-Makefile.incl
@@ -0,0 +1,11 @@
+--- Makefile.incl.orig Wed Feb 9 12:03:32 2005
++++ Makefile.incl Tue Mar 1 10:15:48 2005
+@@ -37,7 +37,7 @@
+ VERSION_MAJOR = @MAJOR_VERSION@
+ VERSION_MINOR = @MINOR_VERSION@
+
+-BOINC_CFLAGS= -I$(BOINCDIR)/api -I$(BOINCDIR)/lib
++BOINC_CFLAGS= -I$(BOINCDIR)/include/BOINC
+
+
+ DEBUG_PROG = setiathome-$(VERSION_MAJOR).$(VERSION_MINOR).@host@.debug$(DOTEXEEXT)
diff --git a/astro/boinc-setiathome/files/patch-client::Makefile.in b/astro/boinc-setiathome/files/patch-client::Makefile.in
deleted file mode 100644
index 7fbf79fdbfb9..000000000000
--- a/astro/boinc-setiathome/files/patch-client::Makefile.in
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.in.orig Mon Aug 30 17:31:09 2004
-+++ Makefile.in Thu Oct 4 00:10:02 2004
-@@ -98,11 +98,11 @@
- @RANLIB@ libooura.$(LIBEXT)
-
- $(PROG): main.$(OBJEXT) libooura.$(LIBEXT) $(OBJS)
-- $(CXX) main.$(OBJEXT) $(OBJS) $(LIBS) $(CLIBS) -o $(PROG) $(BOINC_OBJS)
-+ $(CXX) main.$(OBJEXT) $(OBJS) $(LIBS) $(LDFLAGS) $(CLIBS) -o $(PROG) $(BOINC_OBJS)
- strip $(PROG)
-
- $(GUIPROG): $(GUIOBJS) libooura.$(LIBEXT)
-- $(CXX) $(GUIOBJS) $(GUILIBS) $(CLIBS) -o $(GUIPROG).debug $(BOINC_OBJS)
-+ $(CXX) $(GUIOBJS) $(GUILIBS) $(LDFLAGS) $(CLIBS) -o $(GUIPROG).debug $(BOINC_OBJS)
- cp $(GUIPROG).debug $(GUIPROG)
- strip $(GUIPROG)
-
-@@ -115,7 +115,7 @@
- $(CXX) $(CXXFLAGS) $(BOINC_INC) -I.. -I../db -DTEST_VERSION -c -o main_test.$(OBJEXT) main.cpp
-
- setiathome_test$(DOTEXEEXT): main_test.$(OBJEXT) $(OBJS) libooura.$(LIBEXT)
-- $(CXX) main_test.$(OBJEXT) $(OBJS) $(LIBS) $(CLIBS) -o setiathome_test$(DOTEXEEXT) $(BOINC_OBJS)
-+ $(CXX) main_test.$(OBJEXT) $(OBJS) $(LIBS) $(LDFLAGS) $(CLIBS) -o setiathome_test$(DOTEXEEXT) $(BOINC_OBJS)
-
- ../db/sqlrow_client.$(OBJEXT): ../db/sqlrow.cpp ../db/sqlrow.h
- (cd ../db; $(MAKE) sqlrow_client.$(OBJEXT))
diff --git a/astro/boinc-setiathome/files/patch-db::schema_to_class.in b/astro/boinc-setiathome/files/patch-db::schema_to_class.in
deleted file mode 100644
index 7f7324b75fd5..000000000000
--- a/astro/boinc-setiathome/files/patch-db::schema_to_class.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../db/schema_to_class.in.orig Wed Sep 22 18:42:01 2004
-+++ ../db/schema_to_class.in Sun Oct 3 17:28:10 2004
-@@ -22,7 +22,7 @@
- @CAT@ $1 | @TR@ "[A-Z]" "[a-z]" | @SED@ 's/\`//g' >>$filename
-
- @AWK@ -f @SAH_TOP_DIR@/db/schema_to_class.awk $filename
--INDENT=@INDENT@
-+INDENT=
- if test -n "$INDENT"
- then
- @INDENT@ @INDENT_FLAGS@ $filename.h
diff --git a/astro/boinc-setiathome/files/patch-m4-sah_check_boinc.m4 b/astro/boinc-setiathome/files/patch-m4-sah_check_boinc.m4
new file mode 100644
index 000000000000..5f5d14b37549
--- /dev/null
+++ b/astro/boinc-setiathome/files/patch-m4-sah_check_boinc.m4
@@ -0,0 +1,51 @@
+--- m4/sah_check_boinc.m4.orig Fri Dec 24 17:40:58 2004
++++ m4/sah_check_boinc.m4 Tue Mar 1 11:27:23 2005
+@@ -18,29 +18,6 @@
+ fi
+ thisdir=`pwd`
+ AC_MSG_CHECKING([for BOINC])
+- boinc_search_path="$BOINCDIR boinc ../boinc $HOME/boinc /usr/local/boinc /usr/local/lib/boinc /opt/misc/boinc /opt/misc/lib/boinc $2"
+- for boinc_dir in $boinc_search_path
+- do
+- if test -d $boinc_dir
+- then
+- if test -f $boinc_dir/Makefile.am
+- then
+- cd $boinc_dir
+- BOINCDIR=`pwd`
+- cd $thisdir
+- break
+- else
+- if $FIND $boinc_dir -name "Makefile.am" >& /dev/null
+- then
+- BOINCDIR=`$FIND $boinc_dir -name "Makefile.am" -print | $HEAD -1 | sed 's/\/Makefile.am//'`
+- cd $BOINCDIR
+- BOINCDIR=`pwd`
+- cd $thisdir
+- break
+- fi
+- fi
+- fi
+- done
+ if test -n "$BOINCDIR"
+ then
+ AC_MSG_RESULT($BOINCDIR)
+@@ -56,13 +33,13 @@
+ AC_SUBST([PROJECTDIR])
+ AC_SUBST([BOINCDIR])
+ save_libs="$LIBS"
+- RSADIR="$BOINCDIR/RSAEuro"
+- LIBS="$LIBS -L$RSADIR/source"
+- AC_CHECK_LIB([rsaeuro],[RSAPublicEncrypt],[RSALIBS="-L$RSADIR/source -lrsaeuro"])
++ RSADIR="$BOINCDIR"
++ LIBS="$LIBS -L$RSADIR"
++ AC_CHECK_LIB([rsaeuro],[RSAPublicEncrypt],[RSALIBS="-L$RSADIR -lrsaeuro"])
+ LIBS="$save_libs"
+- BOINC_CFLAGS="-I$BOINCDIR/api -I$BOINCDIR/lib"
++ BOINC_CFLAGS="-I$BOINCDIR/include/BOINC"
+ AC_SUBST([BOINC_CFLAGS])
+- RSA_CFLAGS="-I$RSADIR/source"
++ RSA_CFLAGS="-I$BOINCDIR/include/BOINC"
+ AC_SUBST([RSA_CFLAGS])
+ AC_SUBST([RSADIR])
+ AC_SUBST([RSALIBS])
diff --git a/astro/boinc-setiathome/files/patch-m4-sah_header_stdcxx.m4 b/astro/boinc-setiathome/files/patch-m4-sah_header_stdcxx.m4
new file mode 100644
index 000000000000..30cd4fd240cb
--- /dev/null
+++ b/astro/boinc-setiathome/files/patch-m4-sah_header_stdcxx.m4
@@ -0,0 +1,11 @@
+--- m4/sah_header_stdcxx.m4.orig Mon Nov 17 18:33:14 2003
++++ m4/sah_header_stdcxx.m4 Tue Mar 1 10:37:29 2005
+@@ -9,7 +9,7 @@
+ save_inc="$ac_includes_default"
+ ac_includes_default="$ac_includes_default
+ #define CONFIG_TEST
+-#include \"$BOINCDIR/lib/std_fixes.h\"
++#include <BOINC/std_fixes.h>
+ "
+ sah_stdcxx_headers="algorithm bitset cassert cctype cerrno cfloat climits clocale cmath complex csetjmp csignal cstdarg cstddef cstdio cstdlib cstring ctime deque fstream functional iomanip ios iosfwd iostream istream iterator limits list locale map memory numeric ostream queue set sstream stack stdexcept streambuf string utility valarray vector"
+ AC_LANG_PUSH(C++)
diff --git a/astro/boinc-setiathome/files/patch-m4-sah_largefile_breaks_cxx.m4 b/astro/boinc-setiathome/files/patch-m4-sah_largefile_breaks_cxx.m4
new file mode 100644
index 000000000000..6adcd87a3b6b
--- /dev/null
+++ b/astro/boinc-setiathome/files/patch-m4-sah_largefile_breaks_cxx.m4
@@ -0,0 +1,11 @@
+--- m4/sah_largefile_breaks_cxx.m4.orig Mon Nov 17 18:33:14 2003
++++ m4/sah_largefile_breaks_cxx.m4 Tue Mar 1 10:38:00 2005
+@@ -18,7 +18,7 @@
+ [AC_DEFINE([LARGEFILE_BREAKS_CXX],[1],
+ ["Define to 1 if largefile support causes missing symbols in C++"] )
+ tmp_res="yes"
+- sah_cxx_includes=`echo "#include \"$BOINCDIR/lib/std_fixes.h\"" ; echo $sah_cxx_includes`
++ sah_cxx_includes=`echo "#include <BOINC/std_fixes.h>" ; echo $sah_cxx_includes`
+ ]
+ )
+ AC_MSG_RESULT($tmp_res)
diff --git a/astro/boinc-setiathome/pkg-install b/astro/boinc-setiathome/pkg-install
index 3ffb2d593006..29135ede5487 100644
--- a/astro/boinc-setiathome/pkg-install
+++ b/astro/boinc-setiathome/pkg-install
@@ -2,6 +2,6 @@
case $2 in
POST-INSTALL)
- chown %%BOINC_USER%% %%BOINC_HOME%%/projects/%%SETI_SITE%%
- ;;
+ chown %%BOINC_USER%%:%%BOINC_GROUP%% %%BOINC_HOME%%/projects/%%SETI_SITE%%
+ ;;
esac
diff --git a/astro/boinc-setiathome/pkg-plist b/astro/boinc-setiathome/pkg-plist
index e558b6f74baf..37d5d443ab46 100644
--- a/astro/boinc-setiathome/pkg-plist
+++ b/astro/boinc-setiathome/pkg-plist
@@ -1,7 +1,7 @@
@comment @unexec %D/boinc/boinc_client -detach_project %%SETI_SITE%%
-boinc/projects/%%SETI_SITE%%/app_info.xml
-boinc/projects/%%SETI_SITE%%/%%SETI_BINARY%%
-@dirrm boinc/projects/%%SETI_SITE%%
+lib/boinc/%%SETI_BINARY%%
+@comment %%BOINC_GUI%%lib/boinc/%%SETI_BINARY%%.so
@cd %%BOINC_HOME%%
projects/%%SETI_SITE%%/app_info.xml
projects/%%SETI_SITE%%/%%SETI_BINARY%%
+@comment %%BOINC_GUI%%projects/%%SETI_SITE%%/%%SETI_BINARY%%.so