aboutsummaryrefslogtreecommitdiff
path: root/astro/boinc-setiathome
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-22 00:04:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-22 00:04:59 +0000
commitd9efcd3a6ff48f5abea978f8ea76e221126c7b19 (patch)
tree28d287ce8485fd38165e543d9a0dcf22737121ae /astro/boinc-setiathome
parent6580ef6ca8b9e46c8ef02e6dd7ab226ea2e6a3f6 (diff)
downloadports-d9efcd3a6ff48f5abea978f8ea76e221126c7b19.tar.gz
ports-d9efcd3a6ff48f5abea978f8ea76e221126c7b19.zip
- Patch out configure check for jpeg in WITHOUT_X11 case, it's really not
needed PR: ports/80456 Submitted by: J.R. Oldroyd <fbsd@opal.com> (maintainer)
Notes
Notes: svn path=/head/; revision=135819
Diffstat (limited to 'astro/boinc-setiathome')
-rw-r--r--astro/boinc-setiathome/Makefile25
-rw-r--r--astro/boinc-setiathome/files/patch-configure.ac11
2 files changed, 24 insertions, 12 deletions
diff --git a/astro/boinc-setiathome/Makefile b/astro/boinc-setiathome/Makefile
index 2d32ce88498a..457f17b2fcba 100644
--- a/astro/boinc-setiathome/Makefile
+++ b/astro/boinc-setiathome/Makefile
@@ -7,6 +7,7 @@
PORTNAME= boinc-setiathome
PORTVERSION= 4.07.20050218
+PORTREVISION= 1
CATEGORIES= astro
MASTER_SITES= http://setiweb.ssl.berkeley.edu/sah/seti_source/nightly/ \
${MASTER_SITE_LOCAL}
@@ -18,13 +19,6 @@ COMMENT= Setiathome for boinc
.include <bsd.port.pre.mk>
-# Disable GUI on FreeBSD 4.x until
-# undefined reference to `boinc_init_graphics'
-# is fixed
-.if ${OSVERSION} < 500000
-WITHOUT_X11= yes
-.endif
-
# Build with "make -DWITHOUT_X11" if you don't want the boincmgr
# GUI management interface or the "screensaver" status displays
# from any of the client applications.
@@ -32,6 +26,13 @@ WITHOUT_X11= yes
# Defining WITHOUT_X11 removes the dependencies on the X11 libs
# and the glut and jpeg graphics libs.
+# Disable GUI on FreeBSD 4.x until
+# undefined reference to `boinc_init_graphics'
+# is fixed
+.if ${OSVERSION} < 500000
+WITHOUT_X11= yes
+.endif
+
BUILD_DEPENDS+= ${LOCALBASE}/lib/boinc/boinc-client:${PORTSDIR}/net/boinc-client
RUN_DEPENDS+= boinc:${PORTSDIR}/net/boinc-client
LIB_DEPENDS+= fftw.2:${PORTSDIR}/math/fftw
@@ -83,12 +84,12 @@ pre-configure:
post-build:
${SED} -e "s:%%SETI_BINARY%%:${SETI_BINARY}:g" \
- < ${FILESDIR}/app_info.xml > ${WRKDIR}/app_info.xml
+ < ${FILESDIR}/app_info.xml > ${WRKDIR}/app_info.xml
${SED} -e "s:%%SETI_SITE%%:${SETI_SITE}:g" \
- -e "s:%%BOINC_HOME%%:${BOINC_HOME}:g" \
- -e "s:%%BOINC_USER%%:${BOINC_USER}:g" \
- -e "s:%%BOINC_GROUP%%:${BOINC_GROUP}:g" \
- < pkg-install > ${WRKDIR}/pkg-install
+ -e "s:%%BOINC_HOME%%:${BOINC_HOME}:g" \
+ -e "s:%%BOINC_USER%%:${BOINC_USER}:g" \
+ -e "s:%%BOINC_GROUP%%:${BOINC_GROUP}:g" \
+ < pkg-install > ${WRKDIR}/pkg-install
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/client/`${FIND_SETI_BINARY}` ${PREFIX}/lib/boinc/${SETI_BINARY}
diff --git a/astro/boinc-setiathome/files/patch-configure.ac b/astro/boinc-setiathome/files/patch-configure.ac
new file mode 100644
index 000000000000..d29d0c7e38b4
--- /dev/null
+++ b/astro/boinc-setiathome/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig Fri Feb 18 03:00:30 2005
++++ configure.ac Thu Apr 28 10:47:23 2005
+@@ -154,7 +154,7 @@
+ AC_CHECK_LIB([jpeg], [jpeg_start_decompress])
+ SAH_CHECK_SETILIB
+
+-AM_CONDITIONAL(USE_MY_LIBJPEG, [test "${ac_cv_lib_jpeg_jpeg_start_decompress}" != yes])
++AM_CONDITIONAL(USE_MY_LIBJPEG, [test "${enable_gui}" = yes -a "${ac_cv_lib_jpeg_jpeg_start_decompress}" != yes])
+ dnl AC_CHECK_LIB([stdc++], [main])
+
+ SAH_REQUIRES([boinc],[SAH_CHECK_BOINC],["${no_boinc}" = yes],