aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-16 14:31:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-01-16 14:31:17 +0000
commit95462c3ccd8573b64a5785d90020bc4c852ba899 (patch)
tree17b4f7bdacf5d7db30d9e1dab68a5c5f27519587 /astro/celestia
parent3d5e6f0084aff518a8cf18e9c15c3475163d4f21 (diff)
downloadports-95462c3ccd8573b64a5785d90020bc4c852ba899.tar.gz
ports-95462c3ccd8573b64a5785d90020bc4c852ba899.zip
Unbreak the build against new Clang version 6.0.0: struct FavoritesEntry
defines its member `fov' of type `double'; comparing it to NULL is bogus and wrong, no wonder this upsets strict compilers. PR: 224989
Notes
Notes: svn path=/head/; revision=459176
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 3145eb33fd8a..776bfb9c8e84 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -75,6 +75,9 @@ PORTDOCS= AUTHORS ChangeLog README
OPTIONS_DEFINE= DOCS
post-patch:
+ @${REINPLACE_CMD} -E '/fav(->|\.)fov/s|NULL|0.0|' \
+ ${WRKSRC}/src/celestia/celestiacore.cpp \
+ ${WRKSRC}/src/celestia/favorites.cpp
# Fix Lua discovery pkg-config(1) calls
@${REINPLACE_CMD} -E 's|lua5\.?|lua-5.|' ${WRKSRC}/configure
# Remove controversial compiler options (respect our C[XX]FLAGS)