aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-10-28 11:16:35 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-10-28 11:16:35 +0000
commitb1c8d7ab733d43551d87ab0124d32040b71235b0 (patch)
tree4ba0c35d8f4171eb7be7fe79dab3ae02a6886149 /astro/celestia
parent516dda3ededa020af0d5dd0c030302dff8ae5ab3 (diff)
downloadports-b1c8d7ab733d43551d87ab0124d32040b71235b0.tar.gz
ports-b1c8d7ab733d43551d87ab0124d32040b71235b0.zip
Fix build with GCC-based architectures.
PR: 232015 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=483276
Diffstat (limited to 'astro/celestia')
-rw-r--r--astro/celestia/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 776bfb9c8e84..ecc07ec4c628 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
-USES= gettext gmake jpeg libtool lua pkgconfig
+USES= compiler:c++11-lang gettext gl gmake jpeg libtool lua pkgconfig
USE_GL= gl
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/celestia-1.6.1-lua-5.2.patch:-p1 \
@@ -48,6 +48,7 @@ USE_GL+= glut
LDFLAGS+= -lGL
.elif ${CELESTIA_UI} == "gtk"
CONFIGURE_ARGS+= --with-gtk
+USES+= gnome
USE_GNOME+= gtk20
PLIST_FILES= share/applications/celestia.desktop
.elif ${CELESTIA_UI} == "gnome"